1

I have Windows 7 local machine and virtualbox Ubuntu virtual machine. i have installed Postfix on it and configured it, but when I try to send test mail I get the following error (in var/log/mail.log file):

warning: relayhost configuration problem

6027284D93: to=my@yahoo.com, relay=none, delay=54797, delays=54797/0.22/0.06/0, dsn=4.3.5, status=deferred (Host or domain name not found. Name service error for name=testubu.com type=AAAA: Host not found)

my postfix main.cf file:

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# See http://www.postfix.org/COMPATIBILITY_README.html -- default to 2 on
# fresh installs.
compatibility_level = 2

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = mail.testubu.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydomain=testubu.com
myorigin = $mydomain
mydestination = $myhostname, testubu.com, smtp-VirtualBox, localhost.localdomain, localhost,
#relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = ipv4
mail_spool_directory = /var/spool/mail
#proxy_interfaces = 

testubu.com is not real domain

postfix check

postfix status no errors

I have commented relayhost and "warning: relayhost configuration problem" have solved, but I can't send mails. Now in my /var/log/myl.log file:

> connect to rilf-cz.mail.protection.outlook.com[213.199.154.202]:25:
> Connection timed out

When I tried this in terminal:

traceroute -p 25 rilf-cz.mail.protection.outlook.com

I got the following:

traceroute to rilf-cz.mail.protection.outlook.com (213.199.154.202), 64 hops max
  1   10.0.2.2  0,206ms  0,149ms  0,149ms 
  2   10.0.2.2  4,566ms  4,498ms  2,496ms

It looks like, nothing happened out of the virtualbox. I disabled all firewalls I changed the NAT for the bridge. Now the traceroute looks better, but the problem still remains.

connect to alt2.gmail-smtp-in.l.google.com[74.125.68.27]:25: Connection timed out

How can I fix that?

  • 716E6882AE: uid=0 from=<root@smtp-VirtualBox> 716E6882AE: message-id=<20180925094651.716E6882AE@mail.testubu.com> 716E6882AE: from=<root@smtp-VirtualBox>, size=380, nrcpt=1 (queue active) connect to mta7.am0.yahoodns.net[74.6.137.64]:25: Connection timed out connect to mta7.am0.yahoodns.net[98.137.159.25]:25: Connection timed out connect to mta7.am0.yahoodns.net[66.218.85.52]:25: Connection timed out – beslana Sep 25 '18 at 9:53
  • there is no such file. there is cat /var/log/mail.log – beslana Sep 25 '18 at 9:58
  • Can you give the output of ping -w 3 google.com ? – Diogo Jesus Sep 26 '18 at 12:10
  • PING google.com (172.217.169.142) 56(84) bytes of data. 64 bytes from sof02s32-in-f14.1e100.net (172.217.169.142): icmp_seq=1 ttl=53 time=28.6 ms 64 bytes from sof02s32-in-f14.1e100.net (172.217.169.142): icmp_seq=2 ttl=53 time=29.4 ms 64 bytes from sof02s32-in-f14.1e100.net (172.217.169.142): icmp_seq=3 ttl=53 time=28.4 ms – beslana Sep 26 '18 at 12:18
  • from windows telnet myubuntuip 25 'code'telnet 192.168.0.15 25 Trying 192.168.0.15... Connected to 192.168.0.15. Escape character is '^]'. 220 mail.testubu.com ESMTP Postfix (Ubuntu) – beslana Sep 26 '18 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.