1

virt-manager 1:1.5.1 On Ubuntu.

Menu/File/Add Connection/Connect

Error Dialog:

Unable to connect to libvirt qemu:///system

libvirtd.service status shows it is running and that there are no errors

Journal contains following

28153: error : virGetGroupID:1123 : invalid argument: Failed to parse group 'tss'
28153: error : virGetUserID:1043 : invalid argument: Failed to parse user 'tss'

'tss' does not exist as user in /etc/shadow or group in /etc/group

I could simply add tss as user and group. Will that be enough or is this indicative of something I've done wrong? Though I don't know what that could have been because all I've done is install.

I have been happily using VirtualBox for years but VB now requires VT-X which the old target machine does not support. I've tried installing an old VBox but get so many errors (even after --fix-broken) that I don't want to mess with it. So I'm giving virt-manager a try.

UPDATE: I added user tss without any special privilege and the machine now starts. However It does not get far, runs very slowly, because of the lack of CPU virtualization. So... I will not be using this machine for VM.

  • Think VB needs VT-X only if emulating 64bit machines. If you are only emulating 32bit vms, then VB should still work. – ivanivan Sep 24 '18 at 19:23
  • @ivanivan I've tried several 32-bit Ubuntu ISOs and get the Guru Meditation error. However I just tried a 32-bit Debian 9 and it works fine. I will post this over on the Ubuntu group. – Stephen Boston Sep 24 '18 at 19:35
  • This turns out to be a kernel issue. I managed to create an old Ubuntu server 17.10 but after one kernel upgrade it was broken. – Stephen Boston Sep 25 '18 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.