1

I have two partitions that I mount during boot, which aren't on my boot drive (SSD), but on internal HDD. I can access the files fine using Nautilus, I can edit them (e.g. with PhpStorm) but when I try to open a file using the "browse" functionality (e.g. when uploading a file using Firefox or opening a repository in GitKraken) I get a "permission denied" error. I can't even upload a picture of the problem here, so this is what it says:

Could not read the contents of www.
Error opening directory '/media/www': Permission denied

I really don't know what's wrong. Anyone have an idea?

The drives in question are the last 2 lines in my fstab file:

/etc/fstab

UUID=5221e846-702d-47b0-bc92-aad063ae8fcd /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=6C58-64C5  /boot/efi       vfat    umask=0077      0       1
/dev/disk/by-uuid/01D398F590634270 /media/www auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/01D2EB44D1D7F3E0 /media/wouter auto nosuid,nodev,nofail,x-gvfs-show 0 0

mount | grep /dev/sd

/dev/sda5 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/sda2 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sdb3 on /media/www type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096,x-gvfs-show)
/dev/sdb2 on /media/wouter type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096,x-gvfs-show)
7
  • Sorry! copy-paste error! meant to say mount | grep /dev/sd...
    – Fabby
    Sep 24, 2018 at 19:41
  • @Fabby fixed it!
    – Wouter C
    Sep 24, 2018 at 19:45
  • /media/drive does not exist... So uploading from that location will never work: you need to upload from /media/wouter. Can you expand on what you're doing exactly before getting the error message?
    – Fabby
    Sep 24, 2018 at 19:48
  • @Fabby I'm sorry, I renamed the drive to "drive" for convenience, but it's actually "www", so it does exist. An example of what produces the error is when I want to, for example, add a photo to Facebook. When I browse for pictures and click on the drive label, it gives me the error. Another example is trying to open a git repo in GitKraken. When I browse for the repository and click the drive label: same error.
    – Wouter C
    Sep 24, 2018 at 19:58
  • Could you change auto nosuid,nodev,nofail,x-gvfs-show to ntfs-3g rw,inherit,permissions,streams_interface=windows,windows_names,compression,norecover,hide_dot_files,hide_hid_files,big_writes for www and type mount --all after having edited the /etc/fstab and report back?
    – Fabby
    Sep 24, 2018 at 20:01

1 Answer 1

5

I solved the problem. It is a problem with Firefox' permissions.

  1. Open "Ubuntu Software"
  2. Find Firefox in the "Installed" tab and click on it
  3. Choose "Permissions"
  4. Make sure "Read/write files on removable storage devices" is on
2
  • 1
    This saved my day. I was not able browse file from chromium; so I set permission for chromium and then it worked. Thanks a lot bro :) Apr 17, 2020 at 9:20
  • 1
    How does this work with Lubuntu?
    – Timo
    Jul 20, 2020 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .