0

I cannot connect via localhost from Linux Guest to the Windows Host. Here is what I have tried so far:

  1. VM Network settings: NAT.

    • Port Forwarding: Host Port = Guest Port = 8000
    • Guest IP = 10.0.2.15

    (info from linux ifconfig inet configuration).

    I have tried opening 10.0.2.15:8000 or localhost. And when I pinged guest ip from host, it said "request timed out" although guest firewall has been disabled.

  2. VM Network settings: Bridged.

    The result was even worse. It disconnected network on guest.

What am I missing here and what can I do to fix it?

  • I don't understand. What are you trying to connect to, from where? – roaima Sep 24 '18 at 22:38
  • What type of VM system are you using? My experience is that port forwarding is used by a client that is running on the host (or outside of the host) to connect to a server that is running on the guest. Is that what you're trying to do? – Mark Plotnick Sep 24 '18 at 22:53
  • I have virtualbox running on Window and when I run an app on the browser of linux guest, I'd like to open it in the browser of the window host also – Amber Sep 25 '18 at 2:38
0

Try these steps in this link and see if that works for you: https://plenium.wordpress.com/2018/07/03/virtualbox-network-setup-for-internet-access/

| improve this answer | |
  • I followed by adding the 2nd adapter, but when I ran command "ifconfig" in guest, enp0s8 only showed inet6 without inet – Amber Sep 24 '18 at 20:16
  • If you dont get an ipv4 address then you need to setup both a NAT and Host-only adapter. Also try to reboot the VM and see if you get ipv4. – ebeb Sep 25 '18 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.