0

I'm trying to connect using ssh from Window's PuTTY client to Debian Lenny machine without entering password.

For this reason I copied content of \.ssh\id_rsa.pub file to Debian's ~/.ssh/authorized_keys. File authorized_keys was missing so I have created new one with text editor.

After this procedure I tried to connect, but Debian still asks password. What I do wrong?

UPD.

I added key file to putty:

enter image description here

But putty not saves file for configuration. Next time I load connection configuration I must set path to private key:

enter image description here

How to fix that?

  • 2
    It is not clear what id_rsa.pub file you copied. Are you running Pageant? – Kusalananda Sep 24 '18 at 10:16
  • I have copied \.ssh\id_rsa.pub from windows user home directory. It's content starts from ssh-rsa AAAAB... – vico Sep 24 '18 at 10:20
  • 2
    Did you set the permissions correctly? chmod 700 ~/.ssh and chmod 600 ~/.ssh/authorized_keys? Have you told PuTTY which private key to use? – Zwans Sep 24 '18 at 11:03
  • 1
    @vico pkk files are generated by PuTTYgen. You can also ''convert'' an existing private key (keys you generate using ssh-keygen for example) to .pkk format so PuTTY is able to use it. – Zwans Sep 24 '18 at 13:24
  • 1
    The place for saving your configuration changes is under "Sessions" at the top of the Category list. How to make PuTTY settings persistent? – JigglyNaga Sep 26 '18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.