I just recently installed zenwalk linux on my machine, and I am having trouble connecting to my wireless router. I am using the appropriate options such as use encryption, WEP passphrase, the correct passphrase, and so on. It sits there for a minute and gives me an error message of "connection failed: bad password". I have tried everything possible in my power as far as troubleshooting goes. I tried running the wireless configuration through terminal, but I don't believe I am skilled enough to do such a task, as I have not been successful thus far.

2 Answers 2


You should probably start from the basics: identify your wireless card and work out if you have the correct driver: lspci | grep -i net or, if it is a USB device lsusb.

There are a few places where you can check if your card is supported:

If your card doesn't show up here, you'll likely need to resort to ndiswrapper.

You will then need to make sure you have both the Zenwalk wireless tools package and your card's driver and any firmware installed.

After loading your driver, run iwconfig to see that you have an interface such as wlan0 present. Bring the interface up with # ifconfig wlan0 up

Scan for an access point with # iwlist wlan0 scan and then if you are using a hex key with WEP:

# iwconfig wlan0 essid "MyEssid" key 1234567890

Finally provide an IP address to the interface with # dhcpcd wlan0

There is a much more detailed step-through of all of this on the Arch Linux wireless page, including troubleshooting and different options for static IPs etc.

It is worth working through the steps methodically as it will give you both a good understanding of what exactly is happening behind the scenes when you move to a network connection manager (like wicd) and will also pinpoint where exactly your issue is.


Have you tried hooking your PC up to the router with an ethernet cable? At least this way you can diagnose if the problem is with the wireless drivers/hardware or if it is at a higher level.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .