1

System: Linux Mint 19 Cinnamon 64-bit, based on Ubuntu 18.04.

Pidgin: Built from source, version 2.13.0.

Purple Facebook: I'd like to build it from source, version 0.9.5.

But I get missing package error which I cannot locate.


$ ./configure

...

checking for json-glib-1.0 >= 0.14.0... no
configure: error: Package requirements (json-glib-1.0 >= 0.14.0) were not met:

No package 'json-glib-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables JSON_CFLAGS
and JSON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Upon searching for the package, I get similarly named result:

$ apt-cache policy json-glib-1.0

libjson-glib-1.0-0:
  Installed: 1.4.2-3
  Candidate: 1.4.2-3
  Version table:
 *** 1.4.2-3 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

libjson-glib-1.0-common:
  Installed: 1.4.2-3
  Candidate: 1.4.2-3
  Version table:
 *** 1.4.2-3 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/main i386 Packages
        100 /var/lib/dpkg/status

1 Answer 1

0

I had a missing single development package:

sudo apt-get install libjson-glib-dev

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .