1

I am using red hat 6.0 Linux.Currently php 5.3.2 is installed.I want to install phpMyAdmin in it.for that php5.5 is required.

I already installed epel ,remi repository in my system. I am trying to upgrade php version, but it fails because of dependency check.

when I am trying to update the software (System--> Administration --> Software Update),it failed due to Transaction Error.

when I trying to issue command

yum update

it also failed and gives following errors

Error: Package: libzip5-1.5.1-1.el6.remi.i686 (remi)
           Requires: libcrypto.so.10(libcrypto.so.10)
Error: Package: php-5.6.38-1.el6.remi.i686 (remi-php56)
           Requires: libssl.so.10(libssl.so.10)
Error: Package: mysql-libs-5.5.61-1.el6.remi.i686 (remi)
           Requires: libcrypto.so.10(libcrypto.so.10)
Error: Package: php-cli-5.6.38-1.el6.remi.i686 (remi-php56)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)
Error: Package: mysql-libs-5.5.61-1.el6.remi.i686 (remi)
           Requires: libssl.so.10(libssl.so.10)
Error: Package: php-5.6.38-1.el6.remi.i686 (remi-php56)
           Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)
Error: Package: php-cli-5.6.38-1.el6.remi.i686 (remi-php56)
           Requires: libcrypto.so.10(libcrypto.so.10)
Error: Package: php-cli-5.6.38-1.el6.remi.i686 (remi-php56)
           Requires: libssl.so.10(libssl.so.10)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I am not able to understand whats wrong with the system, which packages really required to install phpmyadmin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.