1

My machine sometimes does not properly reboot. I am not sure what triggers it to work or not work. It happens sometimes both during automatic reboots when unattended-upgrades tries to reboot as well as during manual reboot (sudo shutdown -r now).

It seems the machine will stop the services but not actually perform the hardware reboot in the end. If I connect a screen, the last system messages displayed are:

[timestamp] watchdog: watchdog0 did not stop
[timestamp] reboot: Restarting system

I know that it is not just a delay issue, it will stay like this for days and not reboot.

  • OS: Debian GNU/Linux 9 (stretch)
  • Kernel: Linux 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux
  • Hardware: Asus VivoMini Intel N3000

Any ideas what might be wrong?

closed as too broad by user88036, RalfFriedl, maulinglawns, Thomas, countermode Sep 25 '18 at 13:34

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • @Theophrastus: I have a swap partition. I have disabled "quiet" and tried rebooting 10 times, however it did not hang these times. I cannot reproduce the problem right now. Need to wait when it appears next. – RolandU Sep 22 '18 at 18:53
0

It looks like the watchdog is still running when the kernel tries to reboot, and the system still fails to reboot. That indicates a possible firmware/hardware issue: when the kernel stops running, the watchdog should eventually (typically within 10 minutes) force the system to reboot even if the kernel fails to trigger it in the normal way.

If the exact model is Asus VivoMini UN45, here is a list of BIOS updates for it. When you select "Show all" on that page, you'll see that many of the updates have a comment "Improve system stability". If you have a version that is older than one of those updates, updating the BIOS might very well fix your problem.

To know your current BIOS version, run sudo dmidecode -s bios-version. With Asus PCs and motherboards, this command should report a four-digit number that corresponds to the versions listed on the Asus support page for that specific model.

  • Thank you. My BIOS was indeed outdated and I performed an upgrade. Since my problem occurs occasionally without a clear pattern, I cannot be sure this solved it, however I will mark your response as the solution for now. – RolandU Sep 23 '18 at 19:40
0

For the watchdog module that times the time-out and hard resets, the system is simply saying that part can't turn off since the system didn't give the module enough time. This is a normal thing and can be safe to shut down the system manually when it occurs.

  • What can I do to avoid this? This is a headless home server in a closet. Having to go there physically to reboot manually is inconvenient. – RolandU Sep 23 '18 at 7:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.