-1

I got a new computer. This computer works before with a multi boot (ubuntu OS, kali OS and windows OS). I wanted to erase all datas for install only a Kali linux OS (no multi boot, just only Kali).

I installed a kali linux with a usb live. For partitions disk, I manually created :

An EFI partition, a boot partition (ext4, /boot),a swap partition (ext4) and a root partition (ext4, /). Swap and root partition are encrypted.

I haven't any error during the installation, but when I start my laptop, kali does not launch and I have this screen instead :

enter image description here

If I select "kali" or "ubuntu" or "windows" nothing happen. SI, I created a new live usb key with supergrub grub 2 disk (https://www.supergrubdisk.org) and start my computer with this key.

I get this screen :

enter image description here

If I go to "Detect and show boot methods", I get :

enter image description here

enter image description here

And if I select the sixth entry "kali GNU/Linux", the computer start to kali Linux ! this command works !

My question is : how can start on kali automatically without my "super grub2" usb key ?

  • 1
    Turn off the UEFI boot from your bios settings. – GAD3R Sep 26 '18 at 9:30
  • 1
    it works ! thank you :D go write an answer and Ill valid :) – user2137454 Sep 28 '18 at 7:55
1

From the details of SuperGrub2 : Kali linux is installed in the legacy mode (BIOS) , you should turn off the UEFI mode from your BIOS settings.

0

The standard filesystem type for EFI System Partition is FAT32. If you've made it ext4 instead, it is likely the firmware cannot understand that filesystem type.

(Some hardware vendors add extra EFI filesystem drivers to their firmware. Some new PCs have support for NTFS at the EFI firmware level, and Macs with UEFI firmware do support Apple's HFS+. But I haven't heard of any PC that would have ext4 filesystem support in UEFI firmware built-in.)

  • Ok.. I'll reinstall kali and I will say if this is the issue, thank you for your help :) – user2137454 Sep 22 '18 at 17:19
  • I made a mistake in my initial post (I rectified), my EFI partition can't be in EXT4. This is because when I create a new partition I must choose between an EFI partition or an ext4 partition. So, I wasn't able to set an EFI partition in EXT4. I suppose the installer create automatically a EFI with FAT32 – user2137454 Sep 22 '18 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.