1
uname -a

Linux localhost.localdomain 4.13.16-100.fc25.x86_64 #1 SMP Mon Nov 27 19:52:46 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I tried to install ImageMagick using the command:

yum install ImageMagick

Output:

Last metadata expiration check: 0:00:21 ago on Sat 22 Sep 2018 12:45:09 PM MSK.
Dependencies resolved.
================================================================================
 Package                Arch         Version                Repository     Size
================================================================================
Installing:
ImageMagick            x86_64       6.9.9.38-1.fc26        updates       183 k
Upgrading:
ImageMagick-libs       x86_64       6.9.9.38-1.fc26        updates       2.2 M
ImageMagick-perl       x86_64       6.9.9.38-1.fc26        updates       167 k

Transaction Summary
================================================================================
Install  1 Package
Upgrade  2 Packages

Total download size: 2.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): ImageMagick-perl-6.9.9.38-1.fc26.x86_64.  48 kB/s | 167 kB     00:03    
(2/3): ImageMagick-6.9.9.38-1.fc26.x86_64.rpm    52 kB/s | 183 kB     00:03    
(3/3): ImageMagick-libs-6.9.9.38-1.fc26.x86_64. 153 kB/s | 2.2 MB     00:14    
-------------------------------------------------------------------------------
...
...

 Installed:
ImageMagick.x86_64 6.9.9.38-1.fc26                                            

 Upgraded:
ImageMagick-libs.x86_64 6.9.9.38-1.fc26                                       
ImageMagick-perl.x86_64 6.9.9.38-1.fc26  
Complete!

Next, I tried to install ImageMagick-devel:

yum install ImageMagick-devel

Output: (Full output available here.)

...
... So many text...
...

Upgraded:
libdrm.i686 2.4.91-1.fc26             libdrm.x86_64 2.4.91-1.fc26            

Complete!

Then, I ran this command:

seq 125 666 | sed 's/./& /g;/[0789]/d' | shuf | awk 'NR==1{for(i=1;i<=NF;i++)printf("%c ",$i+0x0267f)}' | sed 's/ $//' | imgout -f Symbola

I got this message:

bash: imgout: command not found


I tried the following command:

yum whatprovides '*/imgout'

I got:

Last metadata expiration check: 0:31:27 ago on Sat 22 Sep 2018 12:45:09 PM MSK. Error: No Matches found

My question is: how can I install imgout?

2

3 Answers 3

2

I think that imgout might just be an alias for some variant of this

convert -font Symbola -pointsize 64 -fill black -background white caption:"`tee`" caption.png

Note that you need the Symbola font. Which was corrupted in my Kubuntu (even after reinstall), causing some problems testing.

The script you give produces 3 symbols, they are then rendered in that font and output to an image file that I've called caption.png. On testing this script makes an image of 3 dice with 4, 3, 2 stacked vertically.

For completeness the only reference online to an actual program imgout were uses in Tweets (eg by @eban) and a plugin for graphicsmagick. There is no reference to imgout on imagemagick.org website other than as a placeholder for an output image file.

1
  • Ok, thanks! Just I asked to japanese what is imgout, they tell is tool from ImageMagick. Sep 23, 2018 at 12:45
1

This tool is not part of the ImageMagick upstream. (Source: ImageMagick site.) That's why it's not part of this package.

4
  • I don't see "imgout" (nor "imageout") anywhere on that page? Can you expand further on your answer?
    – pbhj
    Sep 23, 2018 at 20:06
  • 1
    I'm not sure what more there is to say — the looked-for command is not part of imagemagick, which is the explanation for why the command is not part of imagemagick in Fedora.
    – mattdm
    Sep 23, 2018 at 20:32
  • Your addition of "not" clarified your answer. Thank you.
    – pbhj
    Sep 23, 2018 at 20:41
  • 1
    Well, it said "not" before too. I just made it bold. :)
    – mattdm
    Sep 23, 2018 at 20:50
0

You should be able what's inside the installed packages (and thus, if the executable is included and at which path it is) by using rpm -ql $PACKAGE_NAME.

If you want to know which package contains a certain file then you can do as shown here: https://stackoverflow.com/questions/12670517/how-to-find-packages-containing-a-specific-file

2
  • Not helps. A tool imgout not found. Sep 22, 2018 at 10:53
  • 4
    In that case that means that an executable named imgout does not exist in a fedora package. Which source tells you that an executable named imgout exists? Sep 22, 2018 at 12:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .