0

I can't install fail2ban on my CentOS 6.9. Here is my config

# cat /etc/*release

CentOS release 6.9 (Final)
CentOS release 6.9 (Final)
CentOS release 6.9 (Final)

# rpm -q epel-release
epel-release-6-8.noarch

My installation log

# yum install fail2ban
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirror.awanti.com
* epel: ftp.nluug.nl
* extras: mirror.awanti.com
* rpmforge: mirror.nl.leaseweb.net
* updates: mirror.awanti.com
* webtatic: uk.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package fail2ban.noarch 0:0.9.7-1.el7 will be installed
--> Processing Dependency: fail2ban-server = 0.9.7-1.el7 for package: fail2ban-0.9.7-1.el7.noarch
--> Processing Dependency: fail2ban-sendmail = 0.9.7-1.el7 for package: fail2ban-0.9.7-1.el7.noarch
--> Processing Dependency: fail2ban-firewalld = 0.9.7-1.el7 for package: fail2ban-0.9.7-1.el7.noarch
--> Running transaction check
---> Package fail2ban-firewalld.noarch 0:0.9.7-1.el7 will be installed
--> Processing Dependency: firewalld for package: fail2ban-firewalld-0.9.7-1.el7.noarch
---> Package fail2ban-sendmail.noarch 0:0.9.7-1.el7 will be installed
---> Package fail2ban-server.noarch 0:0.9.7-1.el7 will be installed
--> Processing Dependency: python(abi) = 2.7 for package: fail2ban-server-0.9.7-1.el7.noarch
--> Processing Dependency: systemd-python for package: fail2ban-server-0.9.7-1.el7.noarch
--> Processing Dependency: systemd for package: fail2ban-server-0.9.7-1.el7.noarch
--> Processing Dependency: systemd for package: fail2ban-server-0.9.7-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: fail2ban-server-0.9.7-1.el7.noarch (epel)
       Requires: python(abi) = 2.7
       Installed: python-2.6.6-66.el6_8.x86_64 (@base)
           python(abi) = 2.6
       Available: python34-3.4.9-1.el7.x86_64 (epel)
           python(abi) = 3.4
       Available: python36-3.6.6-1.el7.x86_64 (epel)
           python(abi) = 3.6
           python(abi) = 3.6
Error: Package: fail2ban-server-0.9.7-1.el7.noarch (epel)
       Requires: systemd-python
Error: Package: fail2ban-firewalld-0.9.7-1.el7.noarch (epel)
       Requires: firewalld
Error: Package: fail2ban-server-0.9.7-1.el7.noarch (epel)
       Requires: systemd
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

My Python log

# python -V
Python 2.6.6

# python3.6 -V
Python 3.6.6

UPD: Solved with installation python-boto before fail2ban

yum install python-boto
0

If it is possible update the python package to python36 from epel before installing fail2ban.

  • see my updated question – user3013494 Sep 21 '18 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.