2

I've just installed Synaptic and Gparted on my Raspbian Lite. However I can't use them when launching from the desktop. They ask me for the root password which... there isn't.

I have no problem launching them from a terminal using sudo but seems a bit stupid having to use a command to launch a GUI application when they have a perfectly fine GUI executable.

What can I do so they ask me for my password instead of root's?

EDIT:

Finally, what I've have done in order to avoid having the root account enabled is editing the .desktop files.

sudo nano /usr/share/applications/synaptic.desktop

And changed the line that says:

 Exec=synaptic-pkexec

to:

Exec=sudo synaptic-pkexec

Now it doesn't ask for password if the user has sudo privileges.

2

Gparted attempts to elevate itself when it starts via polkit, which prompts you for some authentication through whatever polkit agent you're using
It seems Synaptic also uses polkit

Your options are:

  • Add yourself to the wheel group with $ sudo usermod -aG wheel [user]
    • log out and in again
    • polkit should now ask for you own password
  • Change the way polkit behaves, eg no authentication, or other options
  • Set the root password via $ sudo passwd root, to your own user's password perhaps
    • you might have to first unlock the root user through $ sudo passwd -u root
  • Thanks for the info. Changing the password did the trick. However I am surprised that the people from the distro hadn't fixed that. – potato Sep 20 '18 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.