1

Archlinux on gnome 3.30. Until the most recent update (3.28 -> 3.30) I used snd-aloop constantly to create a virtual sound device. After the update and a system reboot however it doesn't seem to work anymore.

When I do sudo modprobe snd_aloop or sudo modprobe snd-aloop the command exits with 0. The output of lsmod shows snd_aloop too, however within pauvcontrol I can not select the virtual audio device. It's also not listed under the Output devices tab.

Since lsmod shows the module loaded properly I'm not sure where to troubleshoot either.

pactl list short sinks (and sources) don't show the virtual device either.

alsamixer shows loopback under /proc/asound/cards and it's in/out's under /proc/asound/devices. /proc/asound/pcm lists the virutal device too.

What's worth noting is that when I try to use alsamixer to change the volume controls of the virtual soundcard, it says This sound device does not have any capture controls. which I think is weird since there should be two (reg. input and monitor, both listed in /proc/asound/devices).

Logs are looking good to me:

enter image description here

Note that everything else is working fine with my sound and pulseaudio.

  • 2
    Argh! And of course, 2 minutes after writing and posting this question I fix it myself. A simple pulseaudio -k did the trick. If someone can explain why (I've never had to do that before) in the answers I'd still appreciate it. – confetti Sep 19 '18 at 9:35
  • 1
    The usual reason ALSA devices don't show up in Pulseaudio is if something else is using it (or was using it when Pulseaudio started). Restarting Pulseaudio solves that... BTW, you don't need to use snd-aloop if you are running Pulseaudio anyway, Pulseaudio has its own (more efficient) methods to do that, e.g. null sinks, recording from .monitor outputs, module-loop etc. I've tried snd-aloop once, and I much prefer the more flexible Pulseaudio way. – dirkt Sep 19 '18 at 10:20
  • @dirkt You suggested PA's null sink module to me before and I've tried it with success, but it was using a lot more CPU time for me, that's why I'm staying with snd-aloop. – confetti Sep 19 '18 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.