1

I am running Debian 9 (stretch) amd64. I tried to run a program that relies on libc6-dev-i386 to work, but I was unable to install the package using this command:

apt-get install libc6-dev-i386

I get this error

The following packages have unmet dependencies:

libc6-dev-i386 : Depends: libc6-i386 (= 2.24-11+deb9u3) but it is not going to be installed
                 Depends: libc6-dev (= 2.24-11+deb9u3) but 2.27-6 is to be installed
                 Recommends: gcc-multilib but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to downgrade the libc6-i386_2.27-6 version to 2.24-11+deb9u3:

dpkg -i --force-downgrade libc6-i386_2.24-11+deb9u3_amd64.deb. 

but I got this:

 Reading database ... 274743 files and directories currently installed.)
Preparing to unpack libc6-i386_2.24-11+deb9u3_amd64.deb ...
Unpacking libc6-i386 (2.24-11+deb9u3) over (2.24-11+deb9u3) ...
Replaced by files in installed package libc6:i386 (2.27-6) ...
dpkg: dependency problems prevent configuration of libc6-i386:
 libc6-i386 depends on libc6 (= 2.24-11+deb9u3); however:
  Version of libc6:amd64 on system is 2.27-6.

dpkg: error processing package libc6-i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-5) ...
Errors were encountered while processing:
 libc6-i386
  • You have a mixture of packages from Debian 9 and 10. Please edit your question to show the output of apt policy. – Stephen Kitt Sep 19 '18 at 4:14
  • When I tried to edit the question with the apt polycy info, says: "You need at least 10 reputation to post more than 8 links." – xc0d3r Sep 19 '18 at 13:37
  • If you format the output as code (with four spaces at the start of each line, or using the {} button), the links won’t count as links and you’ll be able to edit the question. – Stephen Kitt Sep 19 '18 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.