1

I have two PCs (PC1 and PC2) running Linux Mint 18. I compiled a repository and had built an executable on one PC1, and it ran with no problem. I installed Linux Mint 18 on the other PC2, and tried to run the program, but it output this message:

Libboost_system1.58 missing

I installed libboost-all-dev and tried to run the program once again. Now, it output this message:

Illegal instruction (SIGILL) core dumped (memory image saved).

Would you please let me know what is wrong?

  • 1
    Hi, and welcome on U&L! Could you add more details to your question, such as the URL of that software you're building (if you can) and any hardware difference between the two machines you may be aware of (architecture, CPU family, ...) ? My guess is that the machines are different enough that you need to compile your program on both. – John WH Smith Sep 18 '18 at 17:34
  • I compiled and build a Cryptonote-based anonymous code. Yes, the computers are very different in architecture, but I supposed that the build should be compatible with every computer, taking in mind that at least the version of the OS is the same. Am I wrong? I will try to compile it on the PC-2 – Michael Narper Sep 18 '18 at 18:58
  • 1
  • Not really, I am now trying to compile it, will let you know if it runs without problems :) – Michael Narper Sep 18 '18 at 19:20
  • Yup, it compiled and ran without problem. Huge thanks @JohnWHSmith – Michael Narper Sep 18 '18 at 21:01
2

I re-compiled the program on the PC-2 and then it runs well. As John pointed, the problem could be caused by the difference in the architecture of both computers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.