I am building a new PC, and I can’t install Debian. When I start my USB boot drive, I see the booting menu as below.

enter image description here

Then when I select "Graphical install" and I get the following problem:

enter image description here

When I tried to select simple “Install", I got the same result:

enter image description here

My CPU is Ryzen 2200G with Vega GPU.

  • 2
    A related question (I don't use Debian so I can't tell whether this is a true duplicate): unix.stackexchange.com/questions/291498/…
    – Kusalananda
    Commented Sep 18, 2018 at 9:50
  • This looks like either a driver screwup or a graphics mode that the monitor can't handle. It's been ages since I installed Debian, but the first thing I'd try is to press Ctrl-Alt-F1 to see if text consoles are enabled, both from the initial menu and from the screwed-up screen. If you can get to a text console from the screwed up screen, next step is to check dmesg and/or Xorg.log for what drivers it loaded, and what it thinks it did when it switched modes.
    – dirkt
    Commented Sep 18, 2018 at 12:10
  • Console are broken too. It looks like problem @Kusalananda said. I think it happens becouse Debian 9 use 4.9 kernal as defoult. But Ryzen 3 2200g is new processor and kernal support since 4.17 version. =(
    – Lakremon
    Commented Sep 18, 2018 at 12:16
  • I had a old Debian 9 on my HDD. and now I run it. But I got a lot another problems - gruphic is terrible and my eyes are very tired. I think I'll stop at the ubuntu until it turns out Debian 10
    – Lakremon
    Commented Sep 18, 2018 at 12:20

5 Answers 5


I ran into this exact same issue. I managed to get it going by disabling CSM (Compatibility Support Mode) in the BIOS. This forces the installer into full UEFI mode and it is happy after that.


help--> boot: install vga=normal fb=off


help--> boot: expert vga=normal fb=off


I would try with the second option Install as sometimes the graphical installation would have problems with driver. I had similar issues with one of my old PCs.

  • 3
    I tryed. Last photo it is. =)
    – Lakremon
    Commented Sep 18, 2018 at 9:35
  • ok. I am sorry, I didn't read between pictures.
    – Bala TJ
    Commented Sep 18, 2018 at 10:09
  • Similar issue that is left unanswered for more than a year. unix.stackexchange.com/questions/371006/…
    – Bala TJ
    Commented Sep 18, 2018 at 10:18
  • Please share your solution if you have worked around.
    – Bala TJ
    Commented Sep 24, 2018 at 6:07

I have same behaviour of my Vega FE. And it is a simple way to resolve it. Boot uder UEFI mode and install in simple mode (not Graphics) second position in menu.

And install ask force or not UEFI mode? i use not. And got normal legacy/console version.


Choose the help menu option and then select the option asking about the display.

"old laptops use VGA=...."

Then I was prompted with about 2 dozen display options. Choose a mode by entering the single alphanumeric option corresponding to your setup.

No mouse support, but I can see now.

  • 1
    Thanks Ian, with that fixed, just have to fix wifi firmware (nonfree) and it will be on rails!
    – ElHuevo
    Commented Apr 21, 2022 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .