I run Arch Linux using Systemd and ALSA on a Thinkpad X200 and I have an USB sound card connected, which I use for audio output.

The audio is fine until I suspend my machine with $ systemctl suspend. After resuming, the USB sound card’s audio output is broken and irregularly produces crackling noises.

What is possibly causing this? How can I fix this?

Plugging the USB sound card in and out neither produces this issue nor does it solve it. I don’t have a ~/.asoundrc.

Some information. Here is the dmesg output

Here’s my kernel:

$ uname -srvo
Linux 4.18.6-gnu-1 #1 SMP PREEMPT Sat Sep 8 14:43:46 UTC 2018 GNU/Linux

The USB sound card is actually a DAC, namely FiiO E10. Here’s how ALSA sees it:

$ aplay --list-devices
card 1: Audio [DigiHug USB Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The sound driver I use for the card is apparently snd_usb_audio according to $ lsmod | grep snd.

  • have you managed to fix this yet? – Cyclic3 Oct 1 '18 at 9:50
  • @Cyclic3 No. : / – k.stm Oct 3 '18 at 17:35

This could have multiple causes.

The most likely cause, in my opinion, is a driver issue. Many things get very confused after a suspend, as it appears that the system has turned off, but then suddenly reverted itself back in time. I have known video cards to mangle their memory during a suspend, but never an audio card. If the crackling noise sounds like white noise, then this is what I would bet on. Unfortunately this is rather hard to fix, so I would suggest filing a bug report and seeing where that takes you.

Next most likely is an alsa issue. You could see what happens if you use an alternative (OSS springs to mind), and see if that fixes your problem. It could be a specific application causing this, so look in your mixer to see if anything is producing the sound.

Last on the list is a hardware problem. The DAC may become irreparably confused when the system suspends. But this should either be solved by unplugging it and then plugging it back in again (maybe to a different port), or be stuck in this state forever, which to me rules this out. It might be worth checking on the interwebs for anyone else experiencing issues with this card.

  • Thanks for your answer. It’s most likely not the DAC. It works with another machine, but I have the same issue with another DAC, albeit of the same model. I’ve actually come to believe that the issue is a power issue. – k.stm Sep 30 '18 at 16:15
  • @k.stm this appears to completely rule out the hardware (which looked to be quite unlikely to begin with). As per my answer, I would look at the mixer to see if it is an application, and if not, raise a bug report with alsa. – Cyclic3 Sep 30 '18 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.