When I tried to set up encryption using cryptmount-setup, it just returns without any feedback. It did not even created the crypto.fs file. I ran the commands: cryptmount nextcloud_data and cryptmount -l to show that the creation of the target was clearly unsuccessful, as follows.

Your filing system is now ready to be built - this will involve:
 - Creating the directory "/media/nextcloud_data"
 - Creating a 2700000MB file, "/media/hdd_3tb/crypto.fs"
 - Adding an extra entry ("nextcloud_data") in /etc/cryptmount/cmtab
 - Creating a key-file ("/etc/cryptmount/nextcloud_data.key")
 - Creating an ext3 filingsystem on "/media/hdd_3tb/crypto.fs"
If you do not wish to proceed, no changes will be made to your system.

  Please confirm that you want to proceed (enter "yes")
  [no]: yes
Making mount-point (/media/nextcloud_data)... done
Creating filesystem container (/media/hdd_3tb/crypto.fs)...~ $
~ $
~ $
~ $ cryptmount nextcloud_data
    Target name "nextcloud_data" is not recognized
~ $ cryptmount -l
~ $

I already reduced the size of the crypto-file, to make sure that is not the problem. Any ideas about this issue?

  • Would you please care to expand in the question. not in comments, why the error that you have got in your own pasted text is not a valid feedback? – Rui F Ribeiro Sep 16 '18 at 11:06
  • Was the Creating filesystem container command interrupted or die separately? It didn’t end the line on its own. – Jeff Schaller Sep 17 '18 at 12:49
  • It died on it's own. The reason for the is that I tried to write to a partition as read-only, as you can see in my answer below. I just can't accept it as the solution yet. – user6105651 Sep 17 '18 at 12:53

Cryptmount-setup tries to write to a partition that is mounted in read-only mode, that is why the command exits unexpectedly.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Romeo Ninov Sep 17 '18 at 12:41
  • Thanks for your feedback, I'm new to StackExchange. However I'm not sure how to improve my answer. I'm the author of the question and discovered that I tried to write to a partition that is mounted in read only mode, that is why the cryptmount-setup tool exits. – user6105651 Sep 17 '18 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.