2

I did not use bluetooth on a Linux system before, but I would like to use it right now. I tried to use it and it didn't work at all. Here are some information:

dmesg | grep -i bluetooth

[   21.787508] Bluetooth: Core ver 2.22
[   21.787528] Bluetooth: HCI device and connection manager initialized
[   21.787530] Bluetooth: HCI socket layer initialized
[   21.787532] Bluetooth: L2CAP socket layer initialized
[   21.787535] Bluetooth: SCO socket layer initialized
[   21.961854] Bluetooth: hci0: BCM: chip id 70
[   21.962852] Bluetooth: hci0: BCM: features 0x06
[   21.978852] Bluetooth: hci0: BCM43142A
[   21.978855] Bluetooth: hci0: BCM (001.001.011) build 0000
[   24.604038] Bluetooth: hci0: command 0x0a0a tx timeout
[   26.844010] Bluetooth: hci0: BCM: Patch command 0a0a failed (-19)
[   28.956044] Bluetooth: hci0: command 0x1001 tx timeout
[   37.084103] Bluetooth: hci0: BCM: Reading local version info failed (-110)
[   39.420553] Bluetooth: hci0: command 0x1001 tx timeout
[   47.583855] Bluetooth: hci0: BCM: Reading local version info failed (-110)
[   47.998349] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   47.998351] Bluetooth: BNEP filters: protocol multicast
[   47.998355] Bluetooth: BNEP socket layer initialized

In addition:

hciconfig -a

hci0:   Type: BR/EDR  Bus: USB
    BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
    DOWN 
    RX bytes:318 acl:0 sco:0 events:8 errors:0
    TX bytes:43 acl:0 sco:0 commands:11 errors:0
    Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
    Packet type: DM1 DH1 HV1 
    Link policy: 
    Link mode: SLAVE ACCEPT 

uname -a

Linux xena-HP-Notebook 4.15.0-34-generic #37~16.04.1-Ubuntu SMP Tue Aug 28 10:44:06 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I have tried editing the .config file as suggested by user Goro below. I have also uninstalled Blueberry and installed Blueman in hopes that it might work. I have googled extensively and found that a lot of users face similar issues that correct themselves after a reboot. This hasn't happened in my case. My kernel is updated to the latest one offered under Software Manager.

EDIT: I think bluetooth has been discontinued for kernel 4.15 and newer. I read it someplace. Anyway, it still doesn't work and I'm giving up now.

closed as too broad by Ipor Sircer, RalfFriedl, Michael Homer, Thomas, Thomas Dickey Sep 16 '18 at 17:56

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

As suggested in Linux Mint forum, you can try the following:

-Change #AutoEnable=false to AutoEnable=true in the /etc/bluetooth/main.conf (notice new line is un-commented)
-Unpair the headset
-Restart the bluetooth service sudo /etc/init.d/bluetooth restart
-Pair your headset again and connect it
-Go to sound settings. From the output device tab you should now see the headset listed along with other output device like internal speakers
-Choose it as the sound output device.
  • This doesn't help. Bluetooth is still down and bluetooth manager shows absolutely nothing on screen. – Neetika Bishwas Sep 16 '18 at 15:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.