I would like to run version 14.7 of Xilinx ISE, which is a closed-source software. When it originally came out in 2013, it was supposed to be running on RHEL 6, so I think using CentOS 6.x should be my best option. RHEL v6.4 and RHEL v6.5 are the closest contemporaries of ISE 14.7.

However, when running either version (in a Docker container), the JVM bundled with the ISE fails when generating code for IP cores. I had tried to start java from the ISE installation, and it failed with a weird link-time error:

$ /sdk/fpga/Xilinx/14.7/ISE_DS/ISE/java/lin64/jre/bin/java 
dl failure on line 719Error: 
failed /sdk/fpga/Xilinx/14.7/ISE_DS/ISE/java/lin64/jre/lib/amd64/server/libjvm.so, 
because /sdk/fpga/Xilinx/14.7/ISE_DS/ISE/lib/lin64/libm.so.6: 
symbol __strtold_nan, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

This is with LD_LIBRARY_PATH set by some ISE scripts to:


I've had some success running it on Ubuntu 14.04 and 12.04 Docker images, where the java executable works (with the same LD_LIBRARY_PATH settings), but that too would crash with weird internal libc errors like double-freeing etc. from non-Java parts of the ISE; which is why I want to move on to CentOS.

My question is:

On a fresh version of CentOS 6.5 or 6.4 Docker container, how do I fix glibc so that the JVM bundled with Xilinx ISE works?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.