12

I would like to install Debian 5 on an older PC, because I expect that the kernel of Debian 5 would work better on this computer.

I downloaded the netinstall ISO from debian.org and I tried to install it on a Virtualbox machine. I got this error: Bad mirror. I changed the mirror to archive.debian.org as a hostname, then /debian/ and the problem got resolved.

My problem right now is that the installation stucks on Please wait..., on the screen of Select and install (exactly after choosing what to install - only Standard System - at 13%).

I don't get any errors. I don't know also how to check logs or something else if there exists some.

When I Press CTRL+ALT+F4, I see the following on the screen:

> sep 14 15:36:00 in-target: You should only proceed with the installation if you re certain that
> sep 14 15:36:00 in-target: this is what you want to do.
> sep 14 15:36:00 in-target:
> sep 14 15:36:00 in-target: ispell ibritish wamerican mlocate exim4-config libnfsidmapZ bind9-host
> sep 14 15:36:00 in-target: mime-support libidn11 telnet lsof bash-completion dsutils
> sep 14 15:36:00 in-target: exim4-daemon-light perl libcap2 mutt reportbug libds58 bc m4 doc-debian
> sep 14 15:36:00 in-target: dc at libeuent1 ncurses-term libpcre3 doc-linux-texwhois libsqlite3-0
> sep 14 15:36:00 in-target: python2.5 python-minimal libisccc50 procmail time 1ibrpcsecgss3
> sep 14 15:36:00 in-target: liblwres50 python ftp pciutils dictionaries-commonpython-central w3m
> sep 14 15:36:00 in-target: openbsd-inetd libbind9-50 libxle libgme debian-fafile ucf
> sep 14 15:36:00 in-target: perl-modules python2.5-minimal libldap-2.4-2 libiscfg50 libdb4.5
> sep 14 15:36:00 in-target: bsd-mailx exim4 libgc1c2 exim4-base patch libisc50 libgssgluel iamerican
> sep 14 15:36:00 in-target: portmap nfs-common less libmagicl texinfo liblockfile1
> sep 14 15:36:00 in-target:
> sep 14 15:36:00 in-target: Do you want to ignore this warning and proceed anyway
> sep 14 15:36:00 in-target: To continue, enter "Yes": to abort, enter "No":

What is this warning message about? What can I do?

Important to note that I had tried to install Debian 9 on a VirtualBox and it worked. I tried to install Debian 6 and had the same problem.

13
  • 6
    Why Debian 5? I would select the latest 32-bit release of FreeBSD. – Rui F Ribeiro Sep 14 '18 at 15:16
  • @RuiFRibeiro - Thank you! But why FreeBSD? Should it work well on older computers? – MM PP Sep 14 '18 at 15:18
  • 3
  • 1
    @Alpha3031 I don't think it is really simple to install Debian 5 Kernel in Debian 9. I think there should be problems with systemd as Debian 5 has Kernel v2.6.26. – NETCreator Hosting Sep 15 '18 at 10:21
  • 1
    "cpu stuck on 100%" - That should not happen. I would recommend diagnosing and fixing the problem, instead of using ancient software without security updates. Especially if you actually want to use those machines for something (you still haven't said what you want to use them for). – marcelm Sep 15 '18 at 10:35
25

I would like to install Debian 5 on an older PC, because Debian 5's kernel should work well on this computer.

Umm... no!

That is in fact a Really Bad Idea. There are multiple GNU/Linux distributions available that will run on - and are in fact made for - older 32bit PC's (AntiX, Bodhi etc).

You should never run operating systems that have reach end of life, and as such do not recieve security updates in a timely order.

And I fail to see why an older kernel should work better than a new one, if it is non PAE you are looking for, there are alternatives (see above).

4
  • 1
    Thank you for this answer! I observed that latest Debian is working slowly on my laptop. The CPU is always 100%, even if doing nothing. The screen resolution is recognized as 800*600 (I can't do anything with that). In Windows this laptop is working well. I installed some time ago an older Ubuntu and it worked better (but not best). Now I realized that the Kernel should be the cause and I want to install Debian, Trinity DE, but with older Kernel. I need Debian. So I though I should install an older Debian. Now I am confused as I really want Debian, not other Distro. Thank you! – MM PP Sep 14 '18 at 17:53
  • 1
    I have also an old computer. It has a Pentium IV, 3Ghz. It seems it is working slow with Debian. CPU is almost of the time 100% (the CPU is always 100%, while browsing the web - one tab, simple websites), even with light DE or browser. CentOS 6 seems to work very well on it, as I used it as a webserver too, and tested CentOS. CentOS 6 has an old Kernel. But I need Debian, now. I don't know what to do. – MM PP Sep 14 '18 at 18:01
  • I second AntiX, using it in new hardware. – Rui F Ribeiro Sep 14 '18 at 18:48
  • @MMPP I suggest that you mark this answer as accepted. – Mike Waters Sep 15 '18 at 16:25
6

Please use the archive mirror provided by debian: http://archive.debian.org/debian/

The alternative is to use ISO DVDs, which can be found on their mirror so you do not need network during installation:

https://cdimage.debian.org/mirror/cdimage/archive/5.0.10/amd64/iso-dvd/

6
  • Thank you, Vince! But as I said, I configured it to archive.debian.org/debian/. I don't get "Bad mirror", but the installation stucks on "Please wait...", when it starts "Select and install software" – MM PP Sep 14 '18 at 15:34
  • Pressed CTRL+ALT+F4. I get this: imgur.com/a/NtC8kBD What is the warning? – MM PP Sep 14 '18 at 15:41
  • The packages on archive.debian.org are of little use since the key's expired for Debian 5 (and 6). You'll need an ISO to get something that works, and without a full set, it's pointless. – Thomas Dickey Sep 14 '18 at 16:02
  • @ThomasDickey: Set your clock back to install. Once installed there's a way to order it to ignore the fact the key is expired. – Joshua Sep 14 '18 at 18:18
  • 1
    Thank you, @Joshua. But how to get Debian installed? I am using netinstall as there is no minimal iso. – MM PP Sep 14 '18 at 18:25
6

It seems your first problem from the questions and comments is using the netinstall image. It probably won't work nowadays.

For installing, the best course of action is using the full DVDs.

As for using something modern Debian based that supports 32 bits, you can use AntiX, as others recommended. However, it will be slower, as graphical environments nowadays expect more powerful machines.

I usually run the latest FreeBSD 32-bits on legacy hardware, have regular updates and much more satisfied with the resulting performance.

3

Using old distros is a Windows reflex to solve similar problems.

In fact, the growth of the binaries and the memory/CPU needs have no real reason; Windows is developed on this way, Linux software mostly aren't. In Linux, older software is still available and doesn't allocate significantly more RAM as in the old distro. In exchange, we have better tuned RAM optimization algorithms.

I think the best option is to use a recent distro, but using with older (lesser RAM needed) software. Particularly in the case of the Debian, you can simply drop the gnome/kde/any monstrous windowing subsystems and use simply icewm.1

Furthermore, you can also use the deborphan command to clean up the not very needed packages from your system, particularly if they start daemons what you don't need.

1If you are using it, you can give a try to ratpoison. Keyboard-only VM without window decorations, has only full-screen windows and it is controlled like screen. Its memory need is practically non-existent and lightning fast.

0

So you've seen the installer's aptitude run is hung up at a prompt. If you look just a bit further up in the /var/log/syslog from the part you saw on vt4, you'll see the warning that the prompt is about:

WARNING: untrusted versions of the following packages will be installed!

Further up in the syslog, you can see an error code from during the apt update indicating that the signature didn't validate because of an expired key:

lenny Release: The following signatures were invalid: KEYEXPIRED <...>

As already noted in another comment, one way to defeat this check is to simply set the clock to a time when the key had not yet expired. Depending on what you want to do with this old distro, the consequences of that for other timestamp checks on the system (superblock last mount time, file timestamps used by make, etc.) may be practical to deal with.

If not, another alternative is to configure APT to allow unauthenticated packages and aptitude to ignore trust violations.

You can do this by putting the following /etc/apt/apt.conf settings in the system being installed (as found in an old mailing list post):

APT::Get::AllowUnauthenticated "true";
Aptitude::CmdLine::Ignore-Trust-Violations yes;

i.e.:

  1. Go to the installer's debug shell (Ctrl+Left Alt+F2 for graphical install, Left Alt+F2 for a text install). As the message shown directs, press Enter to get a shell.
  2. Go into the target environment: chroot /target. It will run a shell inside the chroot and give you a shell prompt
  3. To edit /etc/apt/apt.conf and add the settings, run vi /etc/apt/apt.conf, press i and type in the lines noted above. Then press Esc and enter :wq to save and exit vi.
  4. Exit from the chroot: exit
  5. Return to the installation screen with Left Alt+F5 (graphical install) or Left Alt+F1 (text install).

You will need to be far enough along in the installation for the system being installed to be partially installed under /target to be able to chroot to it and use vi. If the installation has already reached the point where it has hung because of the hidden aptitude prompt, you can make the apt.conf change, and then in the debug shell find its aptitude process and kill it:

  1. ps | grep aptitude
  2. kill {aptitude process id number shown in the ps output}

When you go back to the installation screen, the installer will show an error message, but it will give you the option to retry the operation which should succeed with the new settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.