0

I am experiencing a rather unusual problem with my CUDA installation on Linux Mint 18.3. After a clean reboot, running deviceQuery as a standard user: optirun ./deviceQuery returns FAIL, but if I do:

sudo apt install --reinstall libcuda1-390
sudo optirun ./deviceQuery

Then everything works, running optirun ./deviceQuery again returns PASS.

What does sudo do that solves the problem (just reinstalling libcuda1-390 does not help)?

I am using bumblebee to run programs on-demand with the graphics card.

Edit: I am also suspecting the bumblebee installation to be somehow faulty, not CUDA itself.

0

Solved by installing nvidia-modprobe.

  • Care to explain the reason for the downvote? I guess I had a permission problem regarding the process of on-demand loading of nVidia driver. Somehow, nvidia-modprobe, which loads the nVidia kernel module and creates char device files, solved this problem. – Alex Sep 24 '18 at 8:08

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.