1

I'm working with the book Docker in action and I'm trying to work with Docker.

When I run the following commands:

docker run --name export-test \
dockerinaction/ch7_packed:latest ./echo For Export
docker export --output contents.tar export-test 
docker rm export-test
tar -tf contents.tar
the console returns me: 

I get the following error message:

Error response from daemon: OCI runtime create failed:
container_linux.go:348: starting container process caused "exec:
\"/bin/bash\": stat /bin/bash: no such file or directory": unknown.

I tried to find a solution, but could not find one that works. I have rebooted Docker and it is still doesn't works!

1
  • seems to be a common issue. Please see below.
    – user88036
    Sep 14, 2018 at 12:09

1 Answer 1

1

Probably you are running an old version of Linux, or it is just a compatibility issue. Also, this error may indicate an issue with the docker daemon itself, not the container you are trying to run. Try to delete all containers, and restart the daemon. Also try to clean up the docker networks.

Please see here detailed explanation about the problem, and here are the OS requirements for the Docker to work properly. In addition, you can find more information here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .