2

I set up a local repository of packages, copied from the Centos isntallation DVD iso.

The local dns address (myrpmweb) and computer LAN IP successfully loads the Apache 123.. test page, in my Firefox broswer, but trying to load [my local lan ip]/rpm, displays a "Not found, requested url /rpm not found on this server".

I used the steps described here (link), to attempt to setup my own local HTTP repository.

I will go ahead and display the configuration information of the custom repository.

The content of the file /etc/yum.repos.d/kix.repo

name=kix repo
baseurl=file:///home/kix/rpm
enabled=1
gpgcheck=0

There is a folder titled 'repodata', with a lock icon on it, after executing createrepo, in the directory:

/home/kix/rpm/

I've set the proper ownership of the folder, as instructed by the tutorial

chmod -R o-w+r /home/kix/rpm/repo

After transferring the packages from the centos DVD iso to the directory /home/kix//rpm/centos/, I am able to load a package, while the PWD (present-working-directory) is set to there as well:

[root@myserver centos]# yum install jaxen-1.1.3-11.el7.noarch.rpm
Loaded plugins: fastestmirror, langpacks
Examining jaxen-1.1.3-11.el7.noarch.rpm: jaxen-1.1.3-11.el7.noarch
jaxen-1.1.3-11.el7.noarch.rpm: does not update installed package.
Error: Nothing to do

I make a symbolic link to where the packages are transferred to.

 ln -s /var/www/html/repo /home/kix/rpm

Clicking the repo directory in, /var/ww/html/repo, shows the centos folder, and clicking on the centos folder displays packages displayed in, /home/kix/rpm/repo/centos.

ls –la, also confirms the following: total 276

drwxr-xr-x. 3 root root     20 Sep  9 19:59 .
drwxr-xr-x. 5 root root     50 Sep  8 12:30 ..
drwxr-xr-x. 4 kix  kix  221184 Sep  8 12:03 centos

None of the followings loads the repository in firefox, I've also substitued myrpmweb, with my IP address:

http://myrpmweb/rpm
http://myrpmweb/repo
http://myrpmweb/centos

setenforce was set to 0

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=permissive
# SELINUXTYPE= can take one of three two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected.
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

The command, apachectl configtest, displays

AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/httpd/conf.d/vhost.conf:1
Syntax OK

/etc/httpd/conf.d/vhost.conf, displays

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName server.home
    ServerAlias www.example.com
    DocumentRoot /var/www/html/example.com/public_html/
    ErrorLog /var/www/html/example.com/logs/error.log
    CustomLog /var/www/html/example.com/logs/access.log combined
</VirtualHost>

What may be the next step to overcome the problem?

  • 1
    You have provided detail about the configuration of your yum repo, but the error you describe is related to your Apache configuration. The default Apache (httpd) install on CentOS 7 specifies DocumentRoot "/var/www/html" in /etc/httpd/conf. You tried to access myrpmweb/rpm but you added your symbolic link at /var/www/html/repo. Can you access myrpmweb/repo? If you want to test your Apache config separately, try creating a directory at /var/www/html/test and place a text file (e.g. 'hello world') at /var/www/html/test/hello. Can you access myrpmweb/test/hello? – cherdt Sep 13 '18 at 21:58
  • No. the file, /var/www/html/test/hello.txt, refuses to come up when i type, myrpmweb/test/hello, or myrpmweb/test/hello – gimmegimme Sep 14 '18 at 19:41
  • or myrpmweb/test/hello.txt* – gimmegimme Sep 14 '18 at 19:50
0

The solution posted in the following link solved the problem:
https://stackoverflow.com/questions/41917171/apache2-404-error-for-index-html/41917743#41917743

Directory block needed to be defined in the /etc/httpd/conf.d/vhost.conf file

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName server.home
    ServerAlias www.example.com
    DocumentRoot /var/www/html
    ErrorLog /var/log/httpd/error.log
    CustomLog /var/log/httpd/access.log combined
    <Directory "/var/www/html">             # quoted
        AllowOverride All
        Require all granted                 # required in Apache 2.4
    </Directory>
</VirtualHost>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.