0

I have an external USB drive which is formatted in FAT32. That's the output of the fdisk -l command:

/dev/sdb1  *       56 15728639 15728584  7.5G  c W95 FAT32 (LBA)

I have the following entry in my /etc/fstab:

UUID=FAF0-4AE6              /media/usb    vfat      defaults,auto,rw,users,nofail,x-systemd.automount,x-systemd.device-timeout=1      0         0

I am mounting the drive using: sudo mount -a but then everything is owned by root:root and I cannot change the ownership of the different directories and to copy files from my internal partition to the external USB drive. It gives me:

cp: cannot create regular file ... Permission denied

Are my fstab options correct, why I can't use my USB flash drive with regular user's permissions?

1

Vfat partitions don't support file owners/groups. Thus, the Linux kernel has to fake it. By default, it makes root:root own everything. To change this, add uid=youruser,gid=yourgroup to the mount options. Then, that user and group will own everything instead.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.