1

So, I have Windows 7 and Fedora 16 installed on my old HDD. Everything worked well and fine before I've had my new 3TB drive built in, which I initialized as GPT in Windows. Actually I initialized 1,5TB - the rest remains untouched.

After that Fedora won't boot up anymore. Instead it prompts me to maintenance mode, showing something like:

[...]/sbin/blkid -o udev -p /dev/sda[number] [...] terminated by signal 15 (Terminated)

Whenever I press Ctrl+D it shows one or multiple messages similar to that. Using

parted /dev/sdb print

shows that the drive as such is recognized as GPT. It also shows up in /etc/fstab. Using older kernels results in the same problem.

What should I do ?

Edit: I initialized the remaining ~1,5TB in Windows - nothing changed.

  • Now's a great time to upgrade to Fedora 17. – Michael Hampton Sep 1 '12 at 6:17
1

I'd try rebuilding the initial ramdisk:

/sbin/new-kernel-pkg --package kernel --mkinitrd --dracut --depmod --update `uname -r`

Failing that, I'd probably give up and update to F17, which should sort out the problem as well.

  • Thank you for your input, I guess it really is a good idea to upgrade now. – tesseract Sep 2 '12 at 12:59
0

Try reinstall, but reverse the order. Install Win7 first, then Fedora. This method has worked for me. Including Win7 and Win10. Good Luck! 30years

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.