0

On one of our company server, suddenly /usr/lib/sendmail stopped working.

We have a call to it in few scripts (owned and ran by oracle user) and none of them is able to send an email out, even manually doesn't work.

the server is: SunOS 5.10 Generic_Virtual sun4v sparc sun4v

oracle:/home/oracle $ ls -ltr /usr/lib/sendmail
-r-xr-sr-x   1 root     smmsp    1064920 Jan 16  2013 /usr/lib/sendmail

Below the example of a tentative to send mails out:

cat /etc/hosts | /usr/lib/sendmail -f oracle@Smyserver.gov.uk -t fabio.work@mymail.com

This is the output in verbose mode:

oracle@myserver:/home/oracle $ cat /etc/hosts | /usr/lib/sendmail -v -f oracle@myserver.gov.uk -t fabio.work@mymail.com
fabio.work@mymail.com... Connecting to [127.0.0.1] via relay...
220 myserver.gov.uk ESMTP Sendmail 8.14.5+Sun/8.14.5; Tue, 11 Sep 2018 11:04:06 +0100 (BST)
>>> EHLO myserver.gov.uk
250-myserver.gov.uk Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP
>>> VERB
250 2.0.0 Verbose mode
>>> MAIL From:<oracle@myserver.gov.uk> SIZE=126
250 2.1.0 <oracle@myserver.gov.uk>... Sender ok
>>> RCPT To:<fabio.work@mymail.com>
>>> DATA
250 2.1.5 <fabio.work@mymail.com>... Recipient ok
354 Enter mail, end with "." on a line by itself
>>> .
050 <fabio.work@mymail.com>... Connecting to mailhost.gov.uk via relay...
050 MAILER-DAEMON... aliased to postmaster
050 postmaster... aliased to root
050 postmaster... aliased to root
050 root... Connecting to local...
050 220 myserver LMTP ready
050 >>> LHLO myserver.gov.uk
050 250-myserver
050 250-8BITMIME
050 250-ENHANCEDSTATUSCODES
050 250 PIPELINING
050 >>> MAIL From:<>
050 250 2.5.0 ok
050 >>> RCPT To:<root>
050 >>> DATA
050 250 2.1.5 ok
050 354 go ahead
050 >>> .
050 250 2.1.5 root OK
050 root... Sent
250 2.0.0 w8BA46xl008614 Message accepted for delivery
fabio.work@mymail.com... Sent (w8BA46xl008614 Message accepted for delivery)
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 myserver.gov.uk closing connection

Also, i had a look in /var/log/syslog and couldn't find any error/warning message, just mail.info, and this is what i have found in /var/mail/oracle

--w6Q16rOA022071.1532567213/myserver
Content-Type: message/rfc822

Return-Path: <oracle@myserver.gov.uk>
Received: from myserver.gov.uk (localhost [127.0.0.1])
        by myserver.gov.uk (8.14.5+Sun/8.14.5) with ESMTP id w6Q16qOA022069
        for <dbbackups@work.com>; Thu, 26 Jul 2018 02:06:52 +0100 (BST)
Received: (from oracle@localhost)
        by myserver.gov.uk (8.14.5+Sun/8.14.5/Submit) id w6Q16qer022062
        for dbbackups@work.com; Thu, 26 Jul 2018 02:06:52 +0100 (BST)
Date: Thu, 26 Jul 2018 02:06:52 +0100 (BST)
From: oracle@myserver.gov.uk
Message-Id: <201807260106.w6Q16qer022062@myserver.gov.uk>
subject: SUCCESS: Export Logfile from myserver on 00:00 26/07/18 

;;;
Export: Release 11.2.0.4.0 - Production on Thu Jul 26 00:00:00 2018................

I'm not an expert of OS managing, but i'm willing to improve my knowledge.

  • execute with sendmail -v -f and let us know the output – Kamaraj Sep 11 '18 at 10:01
  • 2
    To start on the way to becoming an expert, learn this about problem diagnosis in such systems: Always reach for the logs first, to see what they say about what happened. – JdeBP Sep 11 '18 at 10:06
  • /usr/lib/sendmail? I'm not sure that makes sense. – Rob Sep 11 '18 at 10:21
  • @Rob what do you mean? It stopped to send out mails suddenly, we use sendmail on all our internal servers and this is the only one we don't receive mails – FaMontyN2 Sep 11 '18 at 10:25
  • 1
    /usr/lib/sendmail makes sense. When you say "not working" you mean it's just not reaching the destination? Are you intending to connect to localhost? The output above shows sendmail at least successfully connecting to localhost. – kevlinux Sep 11 '18 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.