0

I posted this question yesterday on stackexchange but I was told that it should have been posted here.

I have installed ProM 6.8 (a process mining tool, written in Java) and after executing the command ./ProM68.sh & in a terminal, the application starts without problems.

I tried to create both a desktop-entry in Gnome 3 (on Fedora 28) or a menu-item.

This is my desktop-entry:

[Desktop Entry]
Name=Prom
Exec=/home/bengbers/Programs/Prom/ProM68.sh %u
Type=Application
StartupNotify=true
Terminal=false  
Categories=Development;Java;

After double-clicking this iscon, nothing happens.

I also tried adding an entry in the main-menu but this entry fails also.

How can I create a working desktop entry?

Ben

  • 2
    Have you placed this file into ~/.local/share/applications as something.desktop? – Ipor Sircer Sep 11 '18 at 9:07
1

If you look at the ProM68.sh script, you can see, that it sets the class path relative to the current working directory, not the directory containing the script. So if you are running ./ProM68.sh your current working directory is the same as the directory containing the script, that's why it works if you run it this way. Desktop files are usually launched with the home directory as current working directory unless you specify a path like Path=/home/bengbers/Programs/Prom. (Also you have some trailing spaces after the false for the Terminal key according to desktop-file-validate, but that's probably not causing any issues.)

  • After adding a line with the Path, the desktop-entry works. Thanks – Ben Engbers Sep 19 '18 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.