-4

I want to temporarily disable SELinux on Centos 7. However, setenforce Permissive has no effect.

# setenforce Permissive
# sestatus
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      31

closed as unclear what you're asking by sebasth, Rui F Ribeiro, Jeff Schaller, Kiwy, jimmij Sep 12 '18 at 1:51

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 6
    sestatus says SELinux is set to permissive, which means SELinux rules are not enforced, only logged. – sebasth Sep 11 '18 at 7:31
2

You cannot disable SELinux without rebooting.

You can set it to Permissive mode at runtime via

setenforce Permissive

or

setenforce 0

In this mode, SELinux behaves like it's disabled; thatis, it does not enforce rules, but just logs any violations of them (in the file /var/log/avc.log, /var/log/audit/audit.log, or /var/log/audit.log, depending on which services are running on your machine).

Not the answer you're looking for? Browse other questions tagged or ask your own question.