0

I am attempting to setup ibus on a fresh Fedora 28.

The problem I currently experience is that it does not let me configure the input method to use Traditional Chinese characters.

Both the configuration button and the Preferences button displayed in the following pictures do absolutely nothing, instead of opening the associated preferences menu as expected:

enter image description here enter image description here

I can manually click, on the second picture, on the fourth button to switch the character set from Simplified to Traditional. However, this is impractical as it needs to be done each time, and the current workflow requires several switches per minute.


What I tried:

  • I tried installing and running ibus-setup. This correctly opens ibus configuration panel, and also allows me to configure additional input methods:

enter image description here

However, it looks like none of these settings is used by the gdm instance of ibus, as no change affects the way in which ibus behaves on my system.

  • I noted that there also seems to be a problem with ibus duplication on the system, for some reasons there are two instances of everything:

    ~$ ps -ef | grep ibus
    gdm       3777  1457  0 06:20 tty1     00:00:00 ibus-daemon --xim --panel disable
    anon      3781  2061  0 06:20 tty2     00:00:00 ibus-daemon --xim --panel disable
    gdm       3786  3777  0 06:20 tty1     00:00:00 /usr/libexec/ibus-dconf
    gdm       3789     1  0 06:20 tty1     00:00:00 /usr/libexec/ibus-x11 --kill-daemon
    gdm       3794  1373  0 06:20 ?        00:00:00 /usr/libexec/ibus-portal
    anon      3797  3781  0 06:20 tty2     00:00:00 /usr/libexec/ibus-dconf
    anon      3798  3781  0 06:20 tty2     00:00:00 /usr/libexec/ibus-extension-gtk3
    anon      3800     1  0 06:20 tty2     00:00:00 /usr/libexec/ibus-x11 --kill-daemon
    anon      3807  1963  0 06:20 ?        00:00:00 /usr/libexec/ibus-portal
    gdm       3818  3777  0 06:20 tty1     00:00:00 /usr/libexec/ibus-engine-simple
    anon      3824  3781  0 06:20 tty2     00:00:00 /usr/libexec/ibus-engine-simple
    anon      5834  3781  0 07:06 tty2     00:00:00 /usr/libexec/ibus-engine-pinyin --ibus
    
  • I also tried to install fcitx, but then I soon realized that this opens another can of worms as there are a bunch of bugs related to the selection of the input method and existing workarounds found online no longer seem to apply for this version of Fedora.


Does anyone have any clue on how to solve this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.