1

I recently upgraded from Jessie to Stretch, and now, while I get an ip address from my router (which is also showing up properly as my default gateway, at least according to "ip r"), and I can access the internet, I can't reach any of my local network directly (tried ping, traceroute, and nslookup).

Local machine's IP address is 192.168.1.115

/etc/network/interfaces:

source /etc/network/interfaces.d/*
iface lo inet loopback

iface eth0 inet manual

auto xenbr0
iface xenbr0 inet dhcp
    bridge_ports eth0

If I ping 192.168.1.1 from my other machine, I get a response, but from this one, I get:

From 192.168.1.115 icmp_seq=1 Destination Host Unreachable

w3m can access google.com, but not 192.168.1.1 (which is accessible through firefox from my other machine).

closed as off-topic by roaima, sourcejedi, RalfFriedl, Thomas, Toby Speight Sep 12 '18 at 11:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – roaima, sourcejedi, RalfFriedl, Thomas, Toby Speight
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Guess: You need to enable something like "clients can talk to each other" on your router. – dirkt Sep 11 '18 at 6:02
  • It seems your router does not include a route to your local network in the DHCP answers it gives, so that's where I would look, and the relevant setting might very well be called something like what @dirkt says. – Henrik Sep 11 '18 at 6:37
  • 1
    @Henrik: The route to the local network on the router must be set, otherwise the client wouldn't get responses from the internet. However, many routers have a "feature" where you can allow/disallow clients to talk to each other (which is implemented with firewall rules). – dirkt Sep 11 '18 at 7:10
  • You're right so far as there needs to be a route to the gateway fro the computer to get traffic to/from it (and through that, the rest of the internet). If the route is (properly) set, traffic to other devices on the local network shouldn't go to the router, but only the switch. As that is nowadays often build into the router, that could intercept the traffic from the "switch" part, and block that so you might be right, in which case another solution would be to inject a proper switch in the network, so traffic between devices doesn't have to go through the "router". – Henrik Sep 11 '18 at 8:21
  • 1
    The machines on my local network could talk to each other without a problem before I upgraded this one's Debian version. Nothing on the router's been changed, just the Debian machine. Could it still be something with the router (or built-in switch in the router?). – Wallphoenix Sep 11 '18 at 16:28
0

A restart without any further changes has resulted in everything working as it ought. As far as I know, the changes I had made either didn't require a restart of any services or were followed by my restarting the particular service that I changed, so I'm not sure what fixed it, unfortunately.

Not the answer you're looking for? Browse other questions tagged or ask your own question.