-2

I use the following command to mount an NFS share from another system on Debian:

sudo mount hypercube.home:/volume1/ /mnt/hypercube/

But this does not persist after boot. I believe I need to add something to fstab but the syntax is probably different and I'm not sure what's the correct syntax for NFS shares.

How can I find out the correct mount syntax and parameters to mount this share automatically at boot on my Debian system?

4

Add a line to /etc/fstab:

hypercube.home:/volume1 /mnt/hypercube nfs4 defaults,_netdev 0 0

If the target system isn’t always on, you might like to check the options described in Debian NFS wait too long when the other Debian is turned off in addition to the above.

1
  • That's it, but you have a typo nsf instead of nfs, took me a while before I noticed it. Thanks. – rfgamaral Sep 10 '18 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.