0

how do i install the package xorg-x11-font-utils for opensuse? I need it for microsoft fonts from here https://downloads.sourceforge.net/project/mscorefonts2/rpms/msttcore-fonts-installer-2.6-1.noarch.rpm but it always complains that iam missing the package xorg-x11-font-utils.

This is the error message it get

sudo rpm -i https://downloads.sourceforge.net/project/mscorefonts2/rpms/msttcore-fonts-installer-2.6-1.noarch.rpm
error: Failed dependencies:
        xorg-x11-font-utils is needed by msttcore-fonts-installer-2.6-1.noarch

Sadly its not packages for opensuse, so i googled but there are only sites which say its suitable for fedora, centos or rhel.

Does somebody know where i can get it for opensuse tumbleweed

  • What release of openSUSE are you running? – Nasir Riley Sep 9 '18 at 18:50
  • Iam using the offical openSUSE Tumbleweed 64bit, VERSION_ID is 20180905 – jsus Sep 9 '18 at 18:57
0

Become root and run the following:

zypper addrepo https://download.opensuse.org/repositories/X11:XOrg/openSUSE_Tumbleweed/X11:XOrg.repo
zypper refresh
zypper install font-util

That will add the repo for font-util, refresh zypper, and install it.

0

SuSE splits up the features that are found in xorg-x11-font-utils (Red Hat) into several packages:

mkfontdir, mkfontscale, bdftopcf, fonttosfnt, font-util

You may have to install all of those to address the installer's requirements (in a quick read of its script, I see mkfontdir and mkfontscale, and none of the packages appears to depend on the others).

However... that's a package dependency. If you have the pieces installed, you can fool rpm by making a dummy package which "provides" the name xorg-x11-font-utils. Detailing that's getting into a new question.

Further reading: Creating a dummy RPM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.