0

I don't know much about the quality of the Lxqt desktop environment per se, but on top of Kubuntu 18.04 it works great.

(It is lighter and more responsive than Plasma 5 (which is good by current standards anyway) and in my case it can take advantage of the KDE Plasma more advanced tools that were already installed, like the Kwin window manager and the Dolphin file manager. - Also, a problem that seems to have always plagued Plasma/KDE, the Kwin crashing rather often, is completely gone in Lxqt.)

So, I want Dolphin as the default file manager, which it is:

$ xdg-mime query default inode/directory
org.kde.dolphin.desktop

But the desktop interaction (desktop "paint", as some people call it) is administered by PCManFM-Qt, not Dolphin. Folders on the desktop are opened in PCManFM-Qt.

Would it be possible to set Dolphin to take over the desktop too?


I can stop PCManFM from administering the desktop as said here:

"disable the so-called LXQt module "Desktop" in "LXQt Session Settings" (binary lxqt-config-session) - Basic Settings"

enter image description here

But in this way I have no desktop at all: some Dolphin module needs to be run at session startup for Dolphin to take over. How to do that?

  • Sup ciprus. Here I am hoping this doesn't turn in to another vlc-subtitles problem where I have to pick up some language I've never seen before and write the patch. ;) Good luck though. – RobotHumans Sep 9 '18 at 16:18
  • @RobotHumans -- well.. unix.stackexchange.com/q/467880/32012 – user32012 Sep 9 '18 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy