1

I am running CentOS7 with postfix and dovecot connect to a mysql backend for user authentication.

When I run doveadm user it responds correctly and the mailboxes get created automatically so I know that doevecot is communicating with mysql.

When I connect with an email client to the machine it also works, but I am not able to send a receive any emails.

Sorting through the logs this is the only thing that pops up which is sort of odd because I am logged in on my pc to the email server.

auth-worker(11685): Info: passwd(jsmith@example.com,11.1.1.1): unknown user

my 10-master.conf looks like this

service auth-worker {
  # Auth worker process is run as root by default, so that it can access
  # /etc/shadow. If this isn't necessary, the user should be changed to
  # $default_internal_user.
  user = vmail
}

closed as too broad by Rui F Ribeiro, RalfFriedl, schily, slm Sep 9 '18 at 2:21

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is SELinux enabled? – maulinglawns Sep 8 '18 at 15:46
  • no I already tried that. – user2236794 Sep 8 '18 at 18:26
  • I am also seeing the following in the logs. private/dovecot-lmtp]: No such file or directory – user2236794 Sep 8 '18 at 18:33
  • I am now able to receive emails, but I am still unable to send. – user2236794 Sep 9 '18 at 2:06

Browse other questions tagged or ask your own question.