-5

This question is an exact duplicate of:

I'm trying to learn some stuff about DNSspoofing, but it didn't work well for me. Here's what i have done. step 1 : turn my NIC into promisc mode using the following command

ifconfig wlan0 promisc

step 2 : make a hosts file for dnsspoof named : /usr/share/dsniff/dnsspoof.hosts (this is suggested in the man page of dnsspoof ) here's what's i typed inside the file

github.com       192.168.1.102
*.github.com     192.168.1.102
www.github.com  192.168.1.102

step 3: run dnsspod with the following command

dnsspoof -i wlan0 -f /usr/share/dsniff/dnsspoof.hosts

then i get this output : image from terminal

everything seems okay to me, but whenever i tried visiting github from my machine or other machine in my network, it didn't go to the given adress 192.168.1.102

marked as duplicate by Ipor Sircer, Stephen Harris, Rui F Ribeiro linux Sep 8 '18 at 13:58

This question was marked as an exact duplicate of an existing question.

1

Your dnsspoof.hosts file is wrong. Read the man page again - it says quite clearly it needs to be in hosts format

Specify the pathname of a file in hosts(5) format. Only one hostname allowed per line (no aliases), although hostnames may contain wildcards (such as *.doubleclick.net).

  • i tried using the hosts file of the system /etc/hosts, but i get an error: INVALID ENTRY – ablil Sep 8 '18 at 17:54
  • Then you have an invalid entry. Perhaps if you'd care to share the entry that's at fault...? – roaima Sep 8 '18 at 18:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.