0

I tried xl console sys-net which is something that works for any other VM (AppVM, TemplateVM), it even works for sys-net-dm (I don't know what that is though)

[ctor@dom0 ~]$ time sudo xl console sys-net
xenconsole: Could not read tty from store: No such file or directory

real    0m5.036s
user    0m0.005s
sys 0m0.015s


[ctor@dom0 ~]$ rpm -qf `which xl`
xen-runtime-4.8.4-2.fc25.x86_64
0

For unknown reasons (bug?) you have to explicitly use the -t flag to specify the console type, which can be any of the two serial of pv. Either works!

So either of the following two work:
sudo xl console -t pv sys-net
sudo xl console -t serial sys-net
But this won't work for sys-net:
sudo xl console sys-net

$ xl console --help
Usage: xl [-v] console [options] <Domain>
-t <type>       console type, pv or serial
-n <number>     console number

Attach to domain's console.

[ctor@dom0 ~]$ sudo xl console -t pv sys-net 

Fedora 28 (Twenty Eight)
Kernel 4.14.67-1.pvops.qubes.x86_64 on an x86_64 (hvc0)

sys-net login:

[ctor@dom0 ~]$ sudo xl console -t serial sys-net 

Fedora 28 (Twenty Eight)
Kernel 4.14.67-1.pvops.qubes.x86_64 on an x86_64 (hvc0)

sys-net login: 

[ctor@dom0 ~]$ sudo xl console sys-net 
xenconsole: Could not read tty from store: No such file or directory

[ctor@dom0 ~]$ rpm -qf `which xl`
xen-runtime-4.8.4-2.fc25.x86_64

Note: Exit console by pressing Ctrl+]

sys-net has Virtualization mode set to HVM. All the other VMs have it set to default (PVH). That seems to be the main difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy