1

I've just installed centos 7.5 in vmware, also installed vmtoolsd and shared folder works.

But the console text is simply too small:

enter image description here

Any ideas? In Xorg I can set DPI but what about console?

0

In the terminal emulator you can go to 'preferences' or a different menu header depending on the terminal emulator.

In here there are settings regarding text size.

Another solution would be changing the resolution of the VM to better suit your display. Lowering the resolution on the VM may be your most effective solution, but it does alter all other UI's in the VM.

  • This is not an X terminal emulator, though. This is the kernel's built-in terminal emulator, as the presence of a login prompt and the questioner's use of the construction In Xorg I can […] but what about console? indicate. – JdeBP Sep 7 '18 at 13:51
0

Most likely what you're wanting to do is add a vga= parameter to your kernel command line.

Best thing to do would be to add vga=ask to the kernel command line in /etc/default/grub and rebuild the GRUB2 configuration:

echo 'GRUB_CMDLINE_LINUX_DEFAULT="vga=ask"' >> /etc/default/grub
grub2-mkconfig -o /boot/grub2/grub.cfg

When you boot up the VM, the kernel will then prompt you for the mode you want. You can then pick the resolution you want from the list.

Here are two options that I've used for VM consoles. Just change vga=ask to one of these and re-run grub2-mkconfig once you've figured out which one is better for you.

  • 640x480x32 resolution: vga=33F
  • 800x600x32 resolution: vga=340

Here's more documentation at kernel.org: https://www.kernel.org/doc/Documentation/svga.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.