1

When I try to connect to x2goserver I get error:

enter image description here

Any idea how to solve it or what are the possible causes?

Both client and remote computers are running Manjaro x64 XFCE and are located in the same LAN network.

4 Answers 4

7

It looks like you forgot to create the database.

sudo x2godbadmin --createdb
2
  • 1
    ^ This was it for me. Specifically running on the client Mar 17, 2019 at 23:10
  • This is it, thank you! (I didn't have to do it when I installed x2goserver on Linux Mint, so I didn't know anything about this command).
    – Kossak
    Mar 29, 2019 at 9:12
3

This message can be caused by a full hard drive. In my case freeing some space solved the problem.

1
  • 1
    This was also the problem in my case. Note for everyone else: It took my a moment to figure out that the problem was a full hard disk on the server, not the client.
    – baltpeter
    Sep 14, 2023 at 8:00
1

I found the solution.

The problem starts from the the installer (from epel) which gives a warning that user x2gouser does not exist. But it does not create the user or a group, and as a result the database created at: /var/lib/x2go/x2go_sessions is owned by root, and only root could login and have a X2Go session. I am not sure why it fails on this release, as it works on CentOS 6, and another 7.

The solution was to create a user: x2gouser and x2gouser group. Then making sure /var/lib/x2go/x2go_sessions has group set as: x2gouser and writable by group (the reinstall when x2gouser was created, did this part).

Finally, the executable: /usr/lib64/x2go/x2gosqlitewrapper should have group membership: x2gouser and set group ID (as root or with sudo run):

chmod g+s /usr/lib64/x2go/x2gosqlitewrapper

Result:

-rwxr-sr-x.  1 root x2gouser  5160 Nov 21  2016 x2gosqlitewrapper

Now, any user that has SSH access and can login on the server, can also create a X2Go session.

0
0

A client had the same issue and apparently it was related to the presence of an user alias at login. When they tried to connect with the alias, which contained uppercase letters, x2go gave that error, while it worked regularly when using the default UNIX username.

1
  • You mean some linux os user alias? I connect as normal linux user, I even tried two different users - one administrator, and one user without administrator rights and the effect is the same.
    – Kossak
    Nov 16, 2018 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .