0

I am trying to disable the intel pstate cpufreq driver and replace it with acpi to get maximum cpu control. I tried this.

vim /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable quiet splash"
or 
GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable" in a separate line
grub-mkconfig -o /boot/grub/grub.cfg
No change so i reboot
reboot

sudo service cpufreqd restart
sudo modprobe acpi-cpufreq

When i do cpufreq-info it still shows

.
.
.analyzing CPU 23:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 23
  CPUs which need to have their frequency coordinated by software: 23
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.30 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.30 GHz and 3.30 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.12 GHz (asserted by call to hardware).
analyzing CPU 24:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 24
  CPUs which need to have their frequency coordinated by software: 24
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.30 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.30 GHz and 3.30 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 2.39 GHz (asserted by call to hardware).
analyzing CPU 25:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 25
  CPUs which need to have their frequency coordinated by software: 25
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.30 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.30 GHz and 3.30 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.26 GHz (asserted by call to hardware).
analyzing CPU 26:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 26
  CPUs which need to have their frequency coordinated by software: 26
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.30 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.30 GHz and 3.30 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 3.27 GHz (asserted by call to hardware).
analyzing CPU 27:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 27
  CPUs which need to have their frequency coordinated by software: 27
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.30 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.30 GHz and 3.30 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 2.17 GHz (asserted by call to hardware).

I have also tried to load the modules by editing /etc/default/modules/acpi to modules="all" and reboot but it does not work

What am i doing wrong here?

1

intel_pstate manages compatible CPUs in a more fine-grained manner than the ACPI driver can, so in general you’re better off letting it handle things.

With recent kernels, it is possible to disable it, in some cases, after boot. To do so, write off to /sys/devices/system/cpu/intel_pstate/status; if this is successful (see the documentation for limitations), you should then be able to use the ACPI driver instead. You might need to disable HWP for this to work; to do that, add intel_pstate=no_hwp to your kernel boot parameters.

(The documentation does mention that intel_pstate=disable should prevent it from registering at all, so the fact that that’s not working for you is somewhat surprising and may indicate a bug.)

  • Yes intel_pstate=disable is not working. I tried intel_pstate=no_hwp but i has created havoc on my system :) – JRD Sep 7 '18 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.