1

i'm trying to get HTTPS web interface for transmission. Currently i can access transmission web interface with http://myip:8081 and what i want is to connect with https://myip/transmission . i already setup my lighttpd with TSL/SSL so i can access to default index page at https://myip

I enabled mod_proxy

lighty-enable-mod proxy

Therefore, in /etc/lighttpd/conf-enabled, i have a 10-proxy.conf which is actually a symlink to /etc/lighttpd/conf-available/10-proxy.conf, and this file contains :

server.modules   += ( "mod_proxy" )

then in lighttpd.conf i added :

$SERVER["socket"] == "0.0.0.0:443" {
    ssl.engine  = "enable"
    ssl.pemfile = "/etc/lighttpd/certs/cert.pem"

    ssl.cipher-list = "ECDHE-RSA-AES256-SHA384:AES256-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH:!AESGCM"
    ssl.honor-cipher-order = "enable"
}

$HTTP["url"] == "^/transmission/" {
        proxy.server = ("" => ( (
                "host" => "127.0.0.1",
                "port" => 8081 
        ))
  )
}

Then I reloaded lighttpd config

service lighttpd force-reload

Conf Syntax is OK but when i want to access to https://myip/transmission/ I've got a 404 not found page.

  • 1
    From your question it is not entirely clear whether the lighttpd is not in the same server as your app. It might be worthwhile also to detail how you enabled mod_proxy – Rui F Ribeiro Sep 7 '18 at 9:07
  • Lighttpd is on same server as transmission app. I enabled lighttpd with lighty-enable-mod proxy . And link 10-proxy.conf is is conf-enabled folder. – MR RsO Sep 7 '18 at 9:12
  • Please detail how you enabled mod_proxy and try to add relevant access error logs generated my lighthttpd. – Rui F Ribeiro Sep 7 '18 at 9:49
  • I put the commands i used to enable mod_proxy – MR RsO Sep 7 '18 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.