4

I have a problem trying to connect with our network webdav share on mac osx. I can connect from windows, so it's working. On Mac OSX I have set the routes, and I can connect when using "Transmit" but not with "Mac Finder" or any other webdav client for mac so it's not a network or login problem, but a problem with the applications. I tried Mac Finder, Cyberduck, AnyClient and lot's of webdav clients from sourceforge. I could buy Transmit, but we have a lot of users and 34$ per license is a lot of money, if you only want to connect to webdav with it.

Situation facts:

  • Two company networks, each with it's own MS ActiveDirectory infrastructure
  • Webdav is in network A, I have an Account for network A
  • My Macbook is in network B, and the routes are set. (as said, works with Transmit)
  • I don't have administrative access to the webdav server, so changing settings is not an option

Since I'm in a different network as the webdav server I need to specify the domain on logon, so login on transmit looks like this:

Protocol: https
Port: 443
Server: 192.168.0.3
Path: webdav_transfer
user: domainA\username (otherwise, the macbook would set domainB as default)

As said, this works on Transmit, but not on any of the other clients. I think it's a problem with the domainA\username part. Somehow transmit can use it, while the others can't. It's also working in Safari, but I can't upload from there.

I already tried the following in mac finder:

https://domainA\[email protected]/webdav_transfer
https://[email protected]/webdav_transfer
https://domainA\\[email protected]/webdav_transfer
https://domainA\\\\[email protected]/webdav_transfer
https://domainA:username:[email protected]/webdav_transfer

I found out that some apps change the URL to

https://domainA%[email protected]/webdav_transfer

So the \ changes to %5C It's probably just a format error, but I don't know how I can get the domainA part properly into my https request.

EDIT: New information:

I tried mounting the webdav share with mount_webdav, which didn't work either - no error message, but the share isn't mounted either. I think (have no proove), that the problem with mount_webdav (and therefore Mac Finder) that it lacks proper ssl support. Through port I installed cadaver, a Unix webdav command line client (sudo port install cadaver). With cadaver I'm able to connect to the webdav share and download/upload stuff. Unfortunately, even though everything works for me now, this is no possible solutions for our maclings (they want a GUI).

I'll keep looking.

1 Answer 1

2

Go to Finder -> Connect to Server... ⌘K

Enter https://192.168.0.3/webdav_transfer as "Server address"

Respond to the Username/Password challenge as "domainA\username" for username.

If that doesn't work, see http://wiki.zimbra.com/wiki/WebDAV for possible reasons; you may be out of luck without admin access to the WebDAV server.

1
  • Thanks, for the link. Brought me one step closer to a solution.
    – mohrphium
    Sep 12, 2012 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .