1

I am trying to scale down one of the CPU frequencies. I am using Ubuntu 14 and Linux kernel 4.4. I want to scale down the cpu3 frequency to 1.2 CONSTANT (no throttle).

Things I have tried:

  1. I want to scale it down by booting with intel_pstate=disable in the /etc/default/grub but upon booting the cpu freqeuency module does not appear anymore. (as per the comments)

    cpupower -c 3 frequency-set -f 1.2 Setting cpu: 3 Error setting new values. Common errors:

    • Do you have proper administration rights? (super-user?) Yes
    • Is the governor you requested available and modprobed?
    • Trying to set an invalid policy?
    • Trying to set a specific frequency, but userspace governor is not available, for example because of hardware which cannot be set to a specific frequency or because the userspace governor isn't loaded? Lack of userspace seems to be the problem
  2. Tried to assign the cpu3 powersave governor and the rest performance governor. This way i could change the ranges. However the changes still appear on ALL the cpus

    cpupower -c 3 frequency-set --governor powersave --min 1200MHz --max 1200MHz

  3. Tried assigning 1.2 to the maximum available frequency file but it generate an error of invalid argument.cpupower -c 3 frequency-set --governor powersave --min 1200MHz --max 1200MHz

  4. Can I install other drivers? The server I am working on is production. Real sensitive. Can't take any chances.

This is the current state of my PC.

Every 0.1s: cat /proc/cpuinfo | grep "^[c]pu MHz"                                                                                                                                  

cpu MHz         : 2902.593
cpu MHz         : 2901.093
cpu MHz         : 2900.343
cpu MHz         : 2901.281
cpu MHz         : 2823.093
cpu MHz         : 2901.843
cpu MHz         : 2900.812
cpu MHz         : 2800.593
cpu MHz         : 2800.218
cpu MHz         : 2800.312
cpu MHz         : 2506.593
cpu MHz         : 2800.406
cpu MHz         : 2800.875
cpu MHz         : 2800.312
cpu MHz         : 2901.281
cpu MHz         : 2901.093
cpu MHz         : 2801.718
cpu MHz         : 2900.812
cpu MHz         : 2899.875
cpu MHz         : 2900.250
cpu MHz         : 2800.406
cpu MHz         : 2800.312
cpu MHz         : 2800.218
cpu MHz         : 2899.968
cpu MHz         : 2800.406
cpu MHz         : 2726.156
cpu MHz         : 2900.437
cpu MHz         : 2900.625

What can I do?

  • 1
    I had the same question once, and the answer i think was to disable pstate kernel parameter. This allows you to use fixed frequency.... I will try to find the right command. – George Vasiliou Sep 6 '18 at 19:03
  • 1
  • Looks like you need userspace governor to use specific frequency for a specific CPU core. What I suggested (in an answer which should be deleted soon because it's useless now) sudo cpupower -c 3 frequency-set --governor powersave --min 1200MHz --max 1200MHz won't work because min/max affect the governor itself, so -c 3 has no effect, it will affect all CPUs and lock them to 1.2GHz at all times. – Marcus Linsner Sep 7 '18 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.