1

I had a perfectly fine and running Solus OS installation on a 100gb of 1tb hard drive. When I created a partition on the remaining 900gb, boot just vanished. I tried all the things from the internet, regarding the Solus or not.

I even don't have the hard drive as a boot option anymore, but I can see the partition and all the files if I boot live CD or other hard disk.

Now the weirdest part: if I attach the "problematic" hard drive to the computer via. USB enclosure I AM ABLE TO BOOT WITHOUT PROBLEM, but still no luck if attached to SATA, so I suspect there must be some problem with EFI.

I tried everything I know and everything I could find on the internet without luck.

Note: there were some updates in Solus that might have messed up the boot, but I doubt as I can regularly boot via USB and not via SATA

EDIT:

I remember I followed this instruction while installing the Solus OS. Boot, swap and main partition are visible via GParted. Boot partition has both boot and esp flags set. GParted also shows that around 300MB disk usage on boot partition that is 500MB large.

I tried the following boot rescue instruction and everything went OK, but the disk still doesn't load.

I also tried to use boot repair tool from Live CD with no luck.

  • "all the things from the Internet" is very vague. Please click on edit above and to the left and tell us specifically what steps you tried, and what the result for each was. Please also advise if you see the EFI system partition en.wikipedia.org/wiki/EFI_system_partition with gparted gparted.org . – K7AAY Sep 6 '18 at 20:27
  • 1
    Fair enough comment, but I just can't really answer what have I tried and what not. I'll update the question with the things I do remember. – Srdjan Marjanovic Sep 7 '18 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.