0

I am using a proxychains on Kali with a DNSCrypt nameserver which operates on port 443. When I start proxychains it tries to connect to the DNS server on port 53 and it returns a timeout. How can I change proxychains to use port 443 for the proxy_dns instead of port 53? And why the DNSCrypt server operates on port 443 and not on port 53?

Thank you!

  • 1
    Welcome to this site! Can you share your proxychains.conf? Take care to anonymize/delete any sensible information! – Mr Shunz Sep 6 '18 at 13:39
  • Thank you! I haven't touched the proxychains.conf file, only the proxyresolv file. I am using DNSCrypt.uk as an example in the file. proxychains.conf proxyresolv – valioww93481 Sep 6 '18 at 14:34
2

I don't really know why DNSCrypt uses the port 443, maybe to prevent conflict with existing DNS resolvers on the same system.

That said, this line in your proxyresolv

dig $1 @$DNS_SERVER +tcp | awk '/A.+[0-9]+\.[0-9]+\.[0-9]/{print $5;}'

assumes a standard port 53 for the resolver.

Just add the option -p 443 to dig:

dig $1 @$DNS_SERVER -p 443 +tcp | awk '/A.+[0-9]+\.[0-9]+\.[0-9]/{print $5;}'

to make it use DNSCrypt port (assuming DNS_SERVER=139.59.200.116 is your DNSCrypt server.

  • DNSCrypt uses 443 because it is DNS over TLS. I also use it. – Rui F Ribeiro Sep 6 '18 at 15:47
  • @RuiFRibeiro well, TLS can be used on any port by any protocol. Probably they chose 443 because is "well known" for security (as to the general public). – Mr Shunz Sep 6 '18 at 15:50
  • yes, that too, because it is usually open in most firewalls. see dnscrypt.info – Rui F Ribeiro Sep 6 '18 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.