0
$ sudo dnf install kernel-latest-4.18.5-8.pvops.qubes.x86_64.rpm kernel-latest-devel-4.18.5-8.pvops.qubes.x86_64.rpm
Qubes OS Repository for Dom0                                                                     25 MB/s |  26 kB     00:00    
Dependencies resolved.
================================================================================================================================
 Package                          Arch                Version                                   Repository                 Size
================================================================================================================================
Installing:
 kernel-latest                    x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               13 M
Upgrading:
 kernel-latest-devel              x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               11 M

Transaction Summary
================================================================================================================================
Install  1 Package
Upgrade  1 Package

Total size: 25 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        1/3 
  Installing  : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              2/3 
  Cleanup     : kernel-latest-devel-1000:4.18.5-7.pvops.qubes.x86_64                                                        3/3 
dracut-install: ERROR: installing '/usr/lib64/plymouth//label.so'
dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.qdDWTG/initramfs -a /usr/share/fonts/dejavu/DejaVuSans.ttf /usr/share/fontconfig/conf.avail/57-dejavu-sans.conf /etc/fonts/conf.d/57-dejavu-sans.conf /etc/fonts/fonts.conf /usr/lib64/plymouth//label.so
  Verifying   : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              1/3 
  Verifying   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        2/3 
  Verifying   : kernel-latest-devel-1000:4.18.5-7.pvops.qubes.x86_64                                                        3/3 

Installed:
  kernel-latest.x86_64 1000:4.18.5-8.pvops.qubes                                                                                

Upgraded:
  kernel-latest-devel.x86_64 1000:4.18.5-8.pvops.qubes                                                                          

Complete!

What's the package that I need to install so that label.so exists and the above doesn't fail?

I tried to find all possible package names containing plymouth in their name:

[ctor@dom0 ~]$ rpm -qa \*plymo\*
plymouth-0.9.3-0.6.20160620git0e65b86c.fc25.x86_64
plymouth-scripts-0.9.3-0.6.20160620git0e65b86c.fc25.x86_64
plymouth-core-libs-0.9.3-0.6.20160620git0e65b86c.fc25.x86_64

[ctor@dom0 ~]$ sudo dnf search \*plymo\*
Last metadata expiration check: 0:07:39 ago on Thu Sep  6 13:53:26 2018.
===================================================== N/S Matched: *plymo* =====================================================
plymouth-scripts.x86_64 : Plymouth related scripts
plymouth-core-libs.x86_64 : Plymouth core libraries
plymouth.x86_64 : Graphical Boot Animation and Logger

$ rpm -qf /usr/lib64/plymouth/label.so
error: file /usr/lib64/plymouth/label.so: No such file or directory

But this seems to list only the already installed ones.

0

The solution is installing plymouth-plugin-label:

$ sudo qubes-dom0-update plymouth-plugin-label
...
Installed:
  plymouth-graphics-libs.x86_64 0.9.3-0.6.20160620git0e65b86c.fc25                                                              
  plymouth-plugin-label.x86_64 0.9.3-0.6.20160620git0e65b86c.fc25        

Testing if solution works(it does):

[ctor@dom0 ~]$ sudo dnf reinstall kernel-latest-4.18.5-8.pvops.qubes.x86_64.rpm kernel-latest-devel-4.18.5-8.pvops.qubes.x86_64.rpm
Qubes OS Repository for Dom0                                                                     25 MB/s |  26 kB     00:00    
Dependencies resolved.
================================================================================================================================
 Package                          Arch                Version                                   Repository                 Size
================================================================================================================================
Reinstalling:
 kernel-latest                    x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               13 M
 kernel-latest-devel              x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               11 M

Transaction Summary
================================================================================================================================

Total size: 25 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Reinstalling: kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        1/4 
  Reinstalling: kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              2/4 
  Erasing     : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        3/4 
  Erasing     : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              4/4 
  Verifying   : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              1/4 
  Verifying   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        2/4 
  Verifying   : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              3/4 
  Verifying   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        4/4 

Reinstalled:
  kernel-latest.x86_64 1000:4.18.5-8.pvops.qubes              kernel-latest-devel.x86_64 1000:4.18.5-8.pvops.qubes             

Complete!

Looks like the way to search for packages containing the text plymo from dom0 is:

$ sudo qubes-dom0-update --action=search \*plymo\*
Using sys-firewall as UpdateVM to download updates for Dom0; this may take some time...
Last metadata expiration check: 0:07:21 ago on Thu Sep  6 13:58:49 2018.
======================= Summary & Name Matched: *plymo* ========================
plymouth-scripts.x86_64 : Plymouth related scripts
plymouth-core-libs.x86_64 : Plymouth core libraries
plymouth-core-libs.i686 : Plymouth core libraries
plymouth-plugin-label.x86_64 : Plymouth label plugin
plymouth-theme-solar.x86_64 : Plymouth "Solar" theme
plymouth-system-theme.x86_64 : Plymouth default theme
plymouth-theme-charge.x86_64 : Plymouth "Charge" plugin
plymouth-theme-script.x86_64 : Plymouth "Script" plugin
plymouth-theme-breeze.x86_64 : Breeze theme for Plymouth
plymouth-plugin-script.x86_64 : Plymouth "script" plugin
plymouth-theme-fade-in.x86_64 : Plymouth "Fade-In" theme
plymouth-theme-spinner.x86_64 : Plymouth "Spinner" theme
plymouth-graphics-libs.i686 : Plymouth graphics libraries
plymouth-graphics-libs.x86_64 : Plymouth graphics libraries
plymouth-plugin-two-step.x86_64 : Plymouth "two-step" plugin
plymouth-theme-hot-dog.noarch : Plymouth Happy Hot Dog Theme
plymouth-theme-spinfinity.x86_64 : Plymouth "Spinfinity" theme
plymouth-plugin-throbgress.x86_64 : Plymouth "Throbgress" plugin
plymouth-plugin-space-flares.x86_64 : Plymouth "space-flares" plugin
plymouth-plugin-fade-throbber.x86_64 : Plymouth "Fade-Throbber" plugin
plymouth-devel.i686 : Libraries and headers for writing Plymouth splash plugins
plymouth-devel.x86_64 : Libraries and headers for writing Plymouth splash
                      : plugins
============================ Name Matched: *plymo* =============================
plymouth.x86_64 : Graphical Boot Animation and Logger
No packages downloaded
Last metadata expiration check: 0:12:45 ago on Thu Sep  6 13:53:26 2018.
===================================================== N/S Matched: *plymo* =====================================================
plymouth-scripts.x86_64 : Plymouth related scripts
plymouth-core-libs.x86_64 : Plymouth core libraries
plymouth.x86_64 : Graphical Boot Animation and Logger

Full details here: https://github.com/QubesOS/qubes-linux-kernel/pull/22#issuecomment-419071786

Double-checking that the solution works(it does):

[ctor@dom0 ~]$ sudo dnf remove kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64 kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64
Dependencies resolved.
================================================================================================================================
 Package                          Arch                Version                                  Repository                  Size
================================================================================================================================
Removing:
 kernel-latest                    x86_64              1000:4.18.5-8.pvops.qubes                @@commandline               63 M
 kernel-latest-devel              x86_64              1000:4.18.5-8.pvops.qubes                @@commandline               44 M

Transaction Summary
================================================================================================================================
Remove  2 Packages

Installed size: 107 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Erasing     : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        1/2 
  Erasing     : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              2/2 
  Verifying   : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              1/2 
  Verifying   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        2/2 

Removed:
  kernel-latest.x86_64 1000:4.18.5-8.pvops.qubes              kernel-latest-devel.x86_64 1000:4.18.5-8.pvops.qubes             

Complete!
[ctor@dom0 ~]$ sudo dnf install kernel-latest-4.18.5-8.pvops.qubes.x86_64.rpm kernel-latest-devel-4.18.5-8.pvops.qubes.x86_64.rpm
Qubes OS Repository for Dom0                                                                     25 MB/s |  26 kB     00:00    
Dependencies resolved.
================================================================================================================================
 Package                          Arch                Version                                   Repository                 Size
================================================================================================================================
Installing:
 kernel-latest                    x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               13 M
 kernel-latest-devel              x86_64              1000:4.18.5-8.pvops.qubes                 @commandline               11 M

Transaction Summary
================================================================================================================================
Install  2 Packages

Total size: 25 M
Installed size: 107 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              1/2 
  Installing  : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        2/2 
  Verifying   : kernel-latest-devel-1000:4.18.5-8.pvops.qubes.x86_64                                                        1/2 
  Verifying   : kernel-latest-1000:4.18.5-8.pvops.qubes.x86_64                                                              2/2 

Installed:
  kernel-latest.x86_64 1000:4.18.5-8.pvops.qubes              kernel-latest-devel.x86_64 1000:4.18.5-8.pvops.qubes             

Complete!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.