2

This question already has an answer here:

I need to dual boot Win10 and encrypted Kali in an UEFI system.

Booting windows is not a problem, i will add an entry in GRUB later, the problem is that as i power on the machine, GRUB loads correctly but gives me just the BASH-like prompt without any menu option.

The drive is shared with Windows but just for additional space, Windows is on another disk.

The disk is partitioned as follow

sda
 sda1 Microsoft reserved
 sda2          (NTFS) data partition
 sda3          (NTFS) data partition
 sda4          (ext2) /boot
 sda5 
   sda5        (crypto LUKS)
     kali-swap (lvm)  swap
     kali-root (lvm)  /
 sda6          (vfat) /boot/efi

I can boot Kali manually issuing these commands to GRUB:

set root=(hd0,4)
linux /vmlinuz root=/dev/mapper/kali-root
initrd /initrd.img
boot

After that, kali boots up without any problem, i tried running update-grub, rebooting but nothing.

i already edited the /etc/default/grub/ file adding GRUB_PRELOAD_MODULES="lvm" and editing the cmd line as follow GRUB_CMDLINE_LINUX_DEFAULT="root=/dev/mapper/kali-root"

i've tried editing the grub.cfg file on the /boot partition

Does anybody know what am i doing wrong?

marked as duplicate by msp9011, schily, Jeff Schaller, Stephen Kitt linux Sep 6 '18 at 14:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • No, I personally suggest you edit grub.cfg, update-grub can be frustrating sometimes. Just add an KaliLinux menuentry containing the commands that works – 炸鱼薯条德里克 Sep 6 '18 at 3:26
  • All right, i'll give it a try and see if it works. – johndoe Sep 6 '18 at 11:18
0

Apparently GRUB was loading the wrong .cfg file.

i found here the answer to my exact same problem

Grub not loading config file or booting into linux automatically

Not the answer you're looking for? Browse other questions tagged or ask your own question.