0

$ sudo journalctl -x -b 0 shows:

Sep 05 00:44:54 dom0 qrexec[4471]: qubes.GetDate: sys-firewall -> @default: allowed to dom0
Sep 05 00:44:54 dom0 runuser[4480]: pam_unix(runuser:session): session opened for user ctor by (uid=0)
Sep 05 00:44:57 dom0 systemd-journald[1213]: Missed 278 kernel messages
-- Subject: Journal messages have been missed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Kernel messages have been lost as the journal system has been unable
-- to process them quickly enough.
Sep 05 00:44:57 dom0 kernel: xen-blkback: backend/vbd/4/51712: using 2 queues, protocol 1 (x86_64-abi) persistent grants
Sep 05 00:44:57 dom0 kernel: xen-blkback: backend/vbd/4/51728: using 2 queues, protocol 1 (x86_64-abi) persistent grants

How can I avoid that Missed n kernel messages / Kernel messages have been lost as the journal system has been unable to process them quickly enough. ?

Here's what I've had already changed from their defaults:

[ctor@dom0 ~]$ grep -nHv '^\s*#'  /etc/systemd/*.conf
/etc/systemd/coredump.conf:13:
/etc/systemd/coredump.conf:14:[Coredump]
/etc/systemd/journald.conf:13:
/etc/systemd/journald.conf:14:[Journal]
/etc/systemd/journald.conf:21:RateLimitIntervalSec=0
/etc/systemd/journald.conf:23:RateLimitBurst=5000
/etc/systemd/journald.conf:25:
/etc/systemd/journald.conf:37:ForwardToSyslog=yes
/etc/systemd/journald.conf:39:ForwardToKMsg=yes
/etc/systemd/journald.conf:41:ForwardToConsole=yes
/etc/systemd/journald.conf:43:ForwardToWall=yes
/etc/systemd/journald.conf:45:TTYPath=/dev/tty12
/etc/systemd/journald.conf:47:MaxLevelStore=debug
/etc/systemd/journald.conf:49:MaxLevelSyslog=debug
/etc/systemd/journald.conf:51:MaxLevelKMsg=debug
/etc/systemd/journald.conf:53:MaxLevelConsole=debug
/etc/systemd/journald.conf:55:MaxLevelWall=emerg
/etc/systemd/logind.conf:13:
/etc/systemd/logind.conf:14:[Login]
/etc/systemd/resolved.conf:13:
/etc/systemd/resolved.conf:14:[Resolve]
/etc/systemd/resolved.conf:16:DNS=
/etc/systemd/resolved.conf:18:FallbackDNS=
/etc/systemd/resolved.conf:21:LLMNR=no
/etc/systemd/resolved.conf:23:DNSSEC=no
/etc/systemd/resolved.conf:25:Cache=yes
/etc/systemd/resolved.conf:26:
/etc/systemd/resolved.conf:28:MulticastDNS=no
/etc/systemd/resolved.conf:29:
/etc/systemd/system.conf:13:
/etc/systemd/system.conf:14:[Manager]
/etc/systemd/system.conf:22:CrashChangeVT=yes
/etc/systemd/system.conf:24:CrashShell=yes
/etc/systemd/system.conf:26:CrashReboot=no
/etc/systemd/system.conf:27:
/etc/systemd/system.conf:31:
/etc/systemd/system.conf:41:DefaultStandardOutput=journal+console
/etc/systemd/system.conf:43:DefaultStandardError=journal+console
/etc/systemd/system.conf:45:DefaultTimeoutStartSec=30s
/etc/systemd/system.conf:47:DefaultTimeoutStopSec=30s
/etc/systemd/timesyncd.conf:13:
/etc/systemd/timesyncd.conf:14:[Time]
/etc/systemd/user.conf:12:
/etc/systemd/user.conf:13:[Manager]

I don't think this has anything to do with rate limiting(see next paragraph), but it might have something to do with forwarding ? though this related question seems to disprove that because it had all forwarding off and the Missed kernel messages still happened.

According to Manual page journald.conf(5):
To turn off any kind of rate limiting, set either value to 0. referring to RateLimitIntervalSec=, RateLimitBurst=. In my case I've RateLimitIntervalSec=0.

sudo dmesg|head -2 is the following (eg. dmesg/log should've plenty of buffer, so this couldn't be why it missed them):

[    0.000000] Linux version 4.14.67-1.pvops.qubes.x86_64 (user@build-fedora4) (gcc version 6.4.1 20170727 (Red Hat 6.4.1-1) (GCC)) #1 SMP Sun Sep 2 04:07:29 UTC 2018
[    0.000000] Command line: root=/dev/mapper/qubes_dom0-root rd.luks.uuid=luks-9ed952b5-2aa8-4564-b700-fb23f5c9e94b rd.lvm.lv=qubes_dom0/root i915.alpha_support=1 rd.luks.options=discard audit=0 root_trim=yes rd.luks.allow-discards ipv6.disable=1 loglevel=15 log_buf_len=16M printk.always_kmsg_dump=y printk.time=y printk.devkmsg=on mminit_loglevel=0 memory_corruption_check=1 fbcon=scrollback:4096k fbcon=font:ProFont6x11 net.ifnames=1 pax_sanitize_slab=full console=tty1 earlyprintk=vga systemd.log_target=kmsg systemd.journald.forward_to_console=1 udev.children-max=1256 rd.udev.children-max=1256

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.