0

Device Information Settings -> System -> About device

SAMSUNG-SM-G900R4, Android version 6.0.1

Computer System Information (Terminal command: uname -a)

Linux debian 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux

Mount USB device using jmtpfs

jmtpfs /media/SAMSUNG-SM-G900R4

ERROR-0

Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
fuse: bad mount point `/media/vassil/SAMSUNG-SM-G900R4': Input/output error

ERROR-1

Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
LIBMTP PANIC: Could not open session! (Return code 8195)
  Try to reset the device.
terminate called after throwing an instance of 'MtpErrorCantOpenDevice'
  what():  Can't open device
Aborted

TESTS
Used different USB cables and tried various combinations of the following:

SAMSUNG-SM-G900R4
Unplug USB cable
Turn on Developer options: Settings -> System -> About device -> tap "Build number" at least 7 times
Set USB options: Settings -> System -> Developer options -> USB debugging: ON, USB configuration: MTP (Media Transfer Protocol)
Restart device
Plug USB cable

Computer
Restart Computer
Mount device: jmtpfs /media/SAMSUNG-SM-G900R4

SAMSUNG-SM-G900R4
If message Allow access to device data appears, then Tap ALLOW.

Computer
Check if you can access device directory: cd /media/SAMSUNG-SM-G900R4; ls

RESULTS
ERROR-0 is displayed, ERROR-1 is displayed, device directory is accessible with some frequencies.

4
  • That suggested duplicate was self-answered, and no points made. Sep 4, 2018 at 20:49
  • It appears to be the same person asking both questions. Vassil, are you attempting to reopen your previous version of this question, or is this supposed to be a new variation that's distinct from the previous one?
    – Jeff Schaller
    Sep 4, 2018 at 21:27
  • @JeffSchaller - definitely not a variation, it's the same (identical) self-answered question, by the same person. Sep 4, 2018 at 21:43
  • @JeffSchaller Yes, I'm trying to reopen previous version of question. Suggested edits were made and it was still closed.
    – Vassil
    Sep 5, 2018 at 14:16

2 Answers 2

2

PERFORM EVERY STEP IN THE SPECIFIED ORDER

SAMSUNG-SM-G900R4

  1. Turn on Developer options: Settings -> System -> About device -> tap "Build number" at least 7 times
  2. Set USB options: Settings -> System -> Developer options -> USB debugging: ON, USB configuration: MTP (Media Transfer Protocol)
  3. Restart device

Computer

  1. Mount device: jmtpfs /media/SAMSUNG-SM-G900R4

SAMSUNG-SM-G900R4

  1. If message Allow access to device data appears, then Tap ALLOW.

Computer

  1. Unmount device: umount /media/SAMSUNG-SM-G900R4
  2. Mount device: jmtpfs /media/SAMSUNG-SM-G900R4
  3. Check if you can access device directory: cd /media/SAMSUNG-SM-G900R4; ls
1
  • How do steps 1 and 2 help? Jan 1, 2022 at 21:51
0

Here is a process that worked for me, though it is brittle.

Keep in mind: once you do the process successfully, and unmount, then you will need to un-plug/re-plug the USB cable to start again. Otherwise, you will get the Restart device message, forever.

So, here we go:

  1. Plug in your device
  2. Run jmtpfs mydir -f -o auto_unmount
    • Note: -f causes it to run in "foreground" mode, not a daemon.
  3. You will get a pop-up on your device, asking for permission. Click 'Accept'.
    • Note: during this period, for me, the target directory will have garbage permissions (shows as ????? in ls) and be un-readable.
    • After you accept, it will still be un-readable. So now, we need to:
  4. Kill the jmtpfs process, with Ctrl-C.
  5. Run it again, this time you can use plain jmtpfs mydir (if you want)
  6. Now, the directory should be usable!
  7. Later, unmount with fusermount -u.
    • Note: as mentioned, un-mounting will permanently make it stop working, for this session. To re-start, you need to un-plug/re-plug the cable, and start at step 1, above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .